summaryrefslogtreecommitdiff
path: root/sys-apps/acl/acl-2.3.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/acl/acl-2.3.1-r2.ebuild')
-rw-r--r--sys-apps/acl/acl-2.3.1-r2.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/sys-apps/acl/acl-2.3.1-r2.ebuild b/sys-apps/acl/acl-2.3.1-r2.ebuild
index e94a237871d1..d89fd34d6a13 100644
--- a/sys-apps/acl/acl-2.3.1-r2.ebuild
+++ b/sys-apps/acl/acl-2.3.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic libtool multilib-minimal usr-ldscript
+inherit flag-o-matic libtool multilib-minimal toolchain-funcs usr-ldscript
DESCRIPTION="Access control list utilities, libraries, and headers"
HOMEPAGE="https://savannah.nongnu.org/projects/acl"
@@ -46,9 +46,7 @@ multilib_src_configure() {
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104964
# https://savannah.nongnu.org/bugs/index.php?62519
# bug #847280
- if is-flagq '-O[23]' || is-flagq '-Ofast' ; then
- # We can't unconditionally do this b/c we fortify needs
- # some level of optimisation.
+ if tc-enables-fortify-source ; then
filter-flags -D_FORTIFY_SOURCE=3
append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
fi