summaryrefslogtreecommitdiff
path: root/sec-keys/openpgp-keys-wget/openpgp-keys-wget-20240415.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sec-keys/openpgp-keys-wget/openpgp-keys-wget-20240415.ebuild')
-rw-r--r--sec-keys/openpgp-keys-wget/openpgp-keys-wget-20240415.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-wget/openpgp-keys-wget-20240415.ebuild b/sec-keys/openpgp-keys-wget/openpgp-keys-wget-20240415.ebuild
new file mode 100644
index 000000000000..779fa661e9b7
--- /dev/null
+++ b/sec-keys/openpgp-keys-wget/openpgp-keys-wget-20240415.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenPGP keys used by GNU wget"
+HOMEPAGE="https://savannah.gnu.org/projects/wget/"
+SRC_URI="https://savannah.gnu.org/project/memberlist-gpgkeys.php?group=wget&download=1 -> ${P}.asc"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - wget.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
+}