summaryrefslogtreecommitdiff
path: root/sec-keys/openpgp-keys-stellarium/openpgp-keys-stellarium-20221229.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sec-keys/openpgp-keys-stellarium/openpgp-keys-stellarium-20221229.ebuild')
-rw-r--r--sec-keys/openpgp-keys-stellarium/openpgp-keys-stellarium-20221229.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-stellarium/openpgp-keys-stellarium-20221229.ebuild b/sec-keys/openpgp-keys-stellarium/openpgp-keys-stellarium-20221229.ebuild
new file mode 100644
index 000000000000..ff78a1340253
--- /dev/null
+++ b/sec-keys/openpgp-keys-stellarium/openpgp-keys-stellarium-20221229.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OpenPGP keys used to sign Stellarium releases"
+HOMEPAGE="https://stellarium.org/ https://github.com/Stellarium/stellarium"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 riscv"
+
+S="${WORKDIR}"
+
+src_install() {
+ local files=( "${FILESDIR}"/stellarium.asc )
+ insinto /usr/share/openpgp-keys
+ newins - stellarium.asc < <(cat "${files[@]}" || die)
+}