summaryrefslogtreecommitdiff
path: root/sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild')
-rw-r--r--sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild b/sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild
new file mode 100644
index 000000000000..3eaf5e975b68
--- /dev/null
+++ b/sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OpenPGP key used to sign fwknop releases"
+HOMEPAGE="https://www.cipherdyne.org/fwknop/index.html"
+SRC_URI="https://www.cipherdyne.org/signing_key -> ${P}.asc"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - fwknop.gpg < <(cat "${files[@]/#/${DISTDIR}/}")
+}