summaryrefslogtreecommitdiff
path: root/sci-visualization/labplot/labplot-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/labplot/labplot-9999.ebuild')
-rw-r--r--sci-visualization/labplot/labplot-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sci-visualization/labplot/labplot-9999.ebuild b/sci-visualization/labplot/labplot-9999.ebuild
index c45f80b7f620..57d676f568d6 100644
--- a/sci-visualization/labplot/labplot-9999.ebuild
+++ b/sci-visualization/labplot/labplot-9999.ebuild
@@ -13,13 +13,13 @@ inherit ecm kde.org
DESCRIPTION="Scientific data analysis and visualisation based on KDE Frameworks"
HOMEPAGE="https://labplot.kde.org/ https://apps.kde.org/labplot2/"
if [[ ${KDE_BUILD_TYPE} = release ]]; then
- SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-2"
SLOT="5"
-IUSE="cantor fftw fits hdf5 libcerf markdown matio netcdf origin root serial telemetry"
+IUSE="cantor excel fftw fits hdf5 libcerf markdown matio netcdf origin root serial telemetry"
DEPEND="
app-text/poppler
@@ -50,6 +50,7 @@ DEPEND="
>=kde-frameworks/kparts-${KFMIN}:5
>=kde-frameworks/kservice-${KFMIN}:5
)
+ excel? ( dev-libs/qxlsx:= )
fftw? ( sci-libs/fftw:3.0= )
fits? ( sci-libs/cfitsio:= )
hdf5? ( sci-libs/hdf5:= )
@@ -76,7 +77,9 @@ src_configure() {
local mycmakeargs=(
-DENABLE_MQTT=OFF # not packaged
-DENABLE_READSTAT=OFF # not packaged
+ -DENABLE_VECTOR_BLF=OFF # not packaged
-DENABLE_CANTOR=$(usex cantor)
+ -DENABLE_EXCEL=$(usex excel)
-DENABLE_FFTW=$(usex fftw)
-DENABLE_FITS=$(usex fits)
-DENABLE_HDF5=$(usex hdf5)