summaryrefslogtreecommitdiff
path: root/sci-visualization/dash/dash-2.10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/dash/dash-2.10.2.ebuild')
-rw-r--r--sci-visualization/dash/dash-2.10.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-visualization/dash/dash-2.10.2.ebuild b/sci-visualization/dash/dash-2.10.2.ebuild
new file mode 100644
index 000000000000..99937d9520d1
--- /dev/null
+++ b/sci-visualization/dash/dash-2.10.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python framework for building ML & data science web apps"
+HOMEPAGE="https://github.com/plotly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# Test need some packages not yet in the tree
+# flask_talisman
+# percy
+# ...
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/flask-compress[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/beautifulsoup4 )"
+
+distutils_enable_tests pytest