summaryrefslogtreecommitdiff
path: root/sci-physics/siscone/siscone-3.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/siscone/siscone-3.0.5.ebuild')
-rw-r--r--sci-physics/siscone/siscone-3.0.5.ebuild21
1 files changed, 20 insertions, 1 deletions
diff --git a/sci-physics/siscone/siscone-3.0.5.ebuild b/sci-physics/siscone/siscone-3.0.5.ebuild
index d66ff8180740..1205f84ddbbf 100644
--- a/sci-physics/siscone/siscone-3.0.5.ebuild
+++ b/sci-physics/siscone/siscone-3.0.5.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="Hadron Seedless Infrared-Safe Cone jet algorithm"
HOMEPAGE="https://siscone.hepforge.org/"
SRC_URI="https://siscone.hepforge.org/downloads/${P}.tar.gz"
@@ -12,6 +14,23 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples"
+BDEPEND="dev-build/autoconf-archive"
+
+PATCHES=(
+ "${FILESDIR}"/0001-configure-fix-broken-bashisms-resulting-in-logic-fai.patch
+)
+
+src_prepare() {
+ default
+
+ # The included copy of this macro is from 2008 and totally broken.
+ # https://bugs.gentoo.org/890780
+ rm m4/ax_prefix_config_h.m4 || die
+
+ # Rebuild after patch to configure.ac, removal of broken macro
+ eautoreconf
+}
+
src_configure() {
econf --disable-static
}