summaryrefslogtreecommitdiff
path: root/sci-physics/root/root-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/root/root-9999.ebuild')
-rw-r--r--sci-physics/root/root-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index d300c32a9370..0b58a32c0138 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -3,7 +3,6 @@
EAPI=6
-CMAKE_BUILD_TYPE=Release
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
@@ -15,11 +14,11 @@ inherit cmake-utils cuda eapi7-ver elisp-common eutils fortran-2 \
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
-IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix emacs +examples
- fits fftw fortran +gdml graphviz +gsl http libcxx +minuit mysql
- odbc +opengl oracle postgres prefix pythia6 pythia8 +python qt5 R
- +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran vc vmc
- +xml xrootd"
+IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix debug emacs
+ +examples fits fftw fortran +gdml graphviz +gsl http libcxx +minuit
+ mysql nosplash odbc +opengl oracle postgres prefix pythia6 pythia8
+ +python qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva
+ +unuran vc vmc +xml xrootd"
if [[ ${PV} =~ "9999" ]] ; then
inherit git-r3
@@ -138,7 +137,9 @@ src_prepare() {
# CSS should use local images
sed -i -e 's,http://.*/,,' etc/html/ROOT.css || die "html sed failed"
- hprefixify core/clingutils/CMakeLists.txt
+ if use nosplash; then
+ sed -i -e '/bool gNoLogo/s@false@true@' rootx/src/rootx.cxx
+ fi
}
# Note: ROOT uses bundled clang because it is patched and API-incompatible
@@ -253,6 +254,7 @@ src_configure() {
${EXTRA_ECONF}
)
+ CMAKE_BUILD_TYPE=$(usex debug Debug Release) \
cmake-utils_src_configure
}