summaryrefslogtreecommitdiff
path: root/sci-physics/root/root-6.30.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/root/root-6.30.9999.ebuild')
-rw-r--r--sci-physics/root/root-6.30.9999.ebuild38
1 files changed, 19 insertions, 19 deletions
diff --git a/sci-physics/root/root-6.30.9999.ebuild b/sci-physics/root/root-6.30.9999.ebuild
index 831e28f81da0..cb1bd02dcaa9 100644
--- a/sci-physics/root/root-6.30.9999.ebuild
+++ b/sci-physics/root/root-6.30.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,19 +8,17 @@ CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
PYTHON_COMPAT=( python3_{9..12} )
-inherit cmake cuda fortran-2 python-single-r1 toolchain-funcs
+inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
+LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
IUSE="+X aqua +asimage cuda cudnn +davix debug +examples fits fftw fortran
- +gdml graphviz +gsl http jupyter libcxx +minuit mpi mysql odbc +opengl
- oracle postgres pythia6 pythia8 +python qt5 R +roofit +root7 shadow
+ +gdml graphviz +gsl +http jupyter libcxx +minuit mpi mysql odbc +opengl
+ oracle postgres pythia6 pythia8 +python qt5 qt6 R +roofit +root7 shadow
sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
-RESTRICT="test"
-PROPERTIES="test_network"
-
if [[ ${PV} =~ "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/root-project/root.git"
@@ -36,16 +34,18 @@ else
SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
fi
-LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
+RESTRICT="test"
+PROPERTIES="test_network"
REQUIRED_USE="
cuda? ( tmva )
cudnn? ( cuda )
- !X? ( !asimage !opengl !qt5 )
+ !X? ( !asimage !opengl !qt5 !qt6 )
davix? ( ssl xml )
jupyter? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
- qt5? ( root7 )
+ qt5? ( root7 http )
+ qt6? ( root7 http )
roofit? ( minuit )
tmva? ( gsl python )
uring? ( root7 )
@@ -79,9 +79,12 @@ CDEPEND="
)
qt5? (
dev-qt/qtcore:5
- dev-qt/qtgui:5
dev-qt/qtwebengine:5[widgets]
)
+ qt6? (
+ dev-qt/qtbase:6
+ dev-qt/qtwebengine:6[widgets]
+ )
)
asimage? ( media-libs/libafterimage[gif,jpeg,png,tiff] )
cuda? ( >=dev-util/nvidia-cuda-toolkit-9.0 )
@@ -168,6 +171,9 @@ src_prepare() {
# with vanilla clang. The patches enable the C++ interpreter to work.
src_configure() {
+
+ filter-lto # https://bugs.gentoo.org/879323
+
local mycmakeargs=(
-DCMAKE_C_COMPILER="$(tc-getCC)"
-DCMAKE_CXX_COMPILER="$(tc-getCXX)"
@@ -276,7 +282,7 @@ src_configure() {
-Dpythia6=$(usex pythia6)
-Dpythia8=$(usex pythia8)
-Dqt5web=$(usex qt5)
- -Dqt6web=OFF
+ -Dqt6web=$(usex qt6)
-Dr=$(usex R)
-Droofit=$(usex roofit)
-Droofit_multiprocess=OFF
@@ -306,6 +312,7 @@ src_configure() {
-Dvdt=OFF
-Dveccore=OFF
-Dvecgeom=OFF
+ -Dwebgui=$(usex http)
-Dx11=$(usex X)
-Dxml=$(usex xml)
-Dxrootd=$(usex xrootd)
@@ -334,10 +341,3 @@ src_install() {
use python && python_optimize
}
-
-pkg_postinst() {
- einfo "Please note that from now on (specifically since sci-physics/root-6.28.00),"
- einfo "ROOT is more closely following FHS (see https://bugs.gentoo.org/666222)."
- einfo "Due to this, it will no longer be possible to install multiple concurrent"
- einfo "versions of ROOT in Gentoo, since that would now cause file collisions."
-}