summaryrefslogtreecommitdiff
path: root/sci-physics/hepmc/hepmc-3.2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/hepmc/hepmc-3.2.5.ebuild')
-rw-r--r--sci-physics/hepmc/hepmc-3.2.5.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sci-physics/hepmc/hepmc-3.2.5.ebuild b/sci-physics/hepmc/hepmc-3.2.5.ebuild
deleted file mode 100644
index b44e68d09043..000000000000
--- a/sci-physics/hepmc/hepmc-3.2.5.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# python3_11 fails
-PYTHON_COMPAT=( python3_{9..10} )
-inherit cmake python-single-r1
-
-MYP=HepMC3-${PV}
-
-DESCRIPTION="Event Record for Monte Carlo Generators"
-HOMEPAGE="https://hepmc.web.cern.ch/hepmc/"
-SRC_URI="https://hepmc.web.cern.ch/hepmc/releases/${MYP}.tar.gz"
-S="${WORKDIR}/${MYP}"
-
-LICENSE="GPL-3+"
-SLOT="3"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test examples python root"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- root? ( sci-physics/root:= )
- doc? (
- app-text/doxygen[dot]
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-latexrecommended
- )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DHEPMC3_ENABLE_ROOTIO=$(usex root ON OFF)
- -DHEPMC3_ENABLE_PYTHON=$(usex python ON OFF)
- -DHEPMC3_ENABLE_TEST=$(usex test ON OFF)
- -DHEPMC3_BUILD_DOCS=$(usex doc ON OFF)
- -DHEPMC3_BUILD_EXAMPLES=$(usex examples ON OFF)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- use examples && docompress -x /usr/share/doc/${PF}/examples
- python_optimize
-}