summaryrefslogtreecommitdiff
path: root/sci-physics/hepmc/hepmc-2.06.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/hepmc/hepmc-2.06.11.ebuild')
-rw-r--r--sci-physics/hepmc/hepmc-2.06.11.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sci-physics/hepmc/hepmc-2.06.11.ebuild b/sci-physics/hepmc/hepmc-2.06.11.ebuild
index 2a135d0936c4..9d22aed74fd1 100644
--- a/sci-physics/hepmc/hepmc-2.06.11.ebuild
+++ b/sci-physics/hepmc/hepmc-2.06.11.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
MYP=HepMC-${PV}
@@ -70,6 +70,9 @@ src_prepare() {
}
src_configure() {
+ # error: ‘hepevt_’ violates the C++ One Definition Rule [-Werror=odr]
+ # Bug 863284
+ filter-lto
# use MeV over GeV and mm over cm
local mycmakeargs=(
-Dlength=$(usex cm CM MM)