summaryrefslogtreecommitdiff
path: root/sci-physics/fastjet/fastjet-3.0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/fastjet/fastjet-3.0.3-r1.ebuild')
-rw-r--r--sci-physics/fastjet/fastjet-3.0.3-r1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/sci-physics/fastjet/fastjet-3.0.3-r1.ebuild b/sci-physics/fastjet/fastjet-3.0.3-r1.ebuild
deleted file mode 100644
index a0395b353394..000000000000
--- a/sci-physics/fastjet/fastjet-3.0.3-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=yes
-
-FORTRAN_NEEDED=plugins
-
-inherit autotools-utils fortran-2 flag-o-matic
-
-DESCRIPTION="Fast implementation of several recombination jet algorithms"
-HOMEPAGE="http://www.fastjet.fr/"
-SRC_URI="http://www.fastjet.fr/repo/${P}.tar.gz"
-
-LICENSE="GPL-2 QPL"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cgal doc examples +plugins static-libs"
-
-RDEPEND="cgal? ( sci-mathematics/cgal )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
- plugins? ( sci-physics/siscone )"
-
-PATCHES=( "${FILESDIR}"/${P}-system-siscone.patch )
-
-src_configure() {
- use cgal && has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
- local myeconfargs=(
- $(use_enable cgal)
- $(use_enable plugins allplugins)
- $(use_enable plugins allcxxplugins)
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- if use doc; then
- doxygen Doxyfile || die
- fi
-}
-
-src_install() {
- autotools-utils_src_install
- use doc && dohtml -r html/*
- if use examples; then
- insinto /usr/share/doc/${PF}
- find example \
- -name Makefile -or Makefile.in -or Makefile.am -delete
- doins -r example/*
- fi
-}