summaryrefslogtreecommitdiff
path: root/sci-physics/bullet/bullet-3.21.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/bullet/bullet-3.21.ebuild')
-rw-r--r--sci-physics/bullet/bullet-3.21.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sci-physics/bullet/bullet-3.21.ebuild b/sci-physics/bullet/bullet-3.21.ebuild
index ba59abb141b6..9a61fccf6b25 100644
--- a/sci-physics/bullet/bullet-3.21.ebuild
+++ b/sci-physics/bullet/bullet-3.21.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake toolchain-funcs
+inherit cmake flag-o-matic toolchain-funcs
DESCRIPTION="Continuous Collision Detection and Physics Library"
HOMEPAGE="https://www.bulletphysics.com/"
@@ -54,6 +54,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror-strict-aliasing
+ # https://bugs.gentoo.org/863275
+ # https://github.com/bulletphysics/bullet3/issues/4590
+ #
+ # Do not trust with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DBUILD_CPU_DEMOS=OFF
-DBUILD_OPENGL3_DEMOS=OFF