summaryrefslogtreecommitdiff
path: root/sci-misc/boinc/boinc-7.8.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/boinc/boinc-7.8.4.ebuild')
-rw-r--r--sci-misc/boinc/boinc-7.8.4.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sci-misc/boinc/boinc-7.8.4.ebuild b/sci-misc/boinc/boinc-7.8.4.ebuild
index b4628e19804e..b1ddba69aff0 100644
--- a/sci-misc/boinc/boinc-7.8.4.ebuild
+++ b/sci-misc/boinc/boinc-7.8.4.ebuild
@@ -55,6 +55,8 @@ DEPEND="${RDEPEND}
PATCHES=(
# >=x11-libs/wxGTK-3.0.2.0-r3 has webview removed, bug 587462
"${FILESDIR}"/fix_webview.patch
+ # xlocale.h was removed in modern glibc, bug 639108
+ "${FILESDIR}"/fix_xlocale.patch
)
S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
@@ -134,6 +136,8 @@ src_install() {
}
pkg_preinst() {
+ gnome2_icon_savelist
+
enewgroup ${PN}
# note this works only for first install so we have to
# elog user about the need of being in video group
@@ -145,7 +149,9 @@ pkg_preinst() {
}
pkg_postinst() {
- gnome2_icon_cache_update
+ if [[ -n ${GNOME2_ECLASS_ICONS} ]]; then
+ gnome2_icon_cache_update
+ fi
elog
elog "You are using the source compiled version of boinc."
@@ -183,5 +189,7 @@ pkg_postinst() {
}
pkg_postrm() {
- gnome2_icon_cache_update
+ if [[ -n ${GNOME2_ECLASS_ICONS} ]]; then
+ gnome2_icon_cache_update
+ fi
}