summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin19160 -> 19325 bytes
-rw-r--r--sci-mathematics/palp/Manifest4
-rw-r--r--sci-mathematics/palp/metadata.xml26
-rw-r--r--sci-mathematics/palp/palp-2.21.ebuild45
4 files changed, 75 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 2f5a6c5d8f15..10806b61d782 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/palp/Manifest b/sci-mathematics/palp/Manifest
new file mode 100644
index 000000000000..f926dada7f16
--- /dev/null
+++ b/sci-mathematics/palp/Manifest
@@ -0,0 +1,4 @@
+DIST PALP-v2.21.tar.bz2 226701 BLAKE2B f2b57b916b011089b11e3e90e42653b243cbc999c4650b867f3a8c22f7a1bc883778d9678310fe4ecce497690b92c6cef71378ee2177da130b4b14c207f2383b SHA512 ab38469fbd78e0e5db437d892e44aec181810c3d5fbe67739081396ea97db2e47facf658335790b8ea6a7e422a090dde95d79413a7980d29a65db1854aa52dc2
+DIST palp-manual-v1.pdf 517953 BLAKE2B 7243794d8bc62c58c8329a9db32958c1929feb27fae1779874a31c16c1e4fd641e4089d029402ad5188f385b4f20dd77fc82506990bcf252289b21ca1b084b58 SHA512 3cf9fe7038981a5c7aa9d73623e17dc7b944bd8b09b32964c196b2231c1621fbe6014e2b45b2b9db092adbdce27cbb72ea65ced5da0b1f010388fbbef1f534f7
+EBUILD palp-2.21.ebuild 1313 BLAKE2B 0a67fb82fb8fc437f7ab8231d9f939c7492d361fc5d367ea4936f3bb6f73a0f9dbd46e7584946c838100c361cd90761d4d070d637dfeb541de8300a151ab1669 SHA512 e75a152123681adc657aa7289d2d766cfe4e3e1b3dcc2d34fcdb9fc4c31e3ed363a673ffaea87dacacc962d14ed499f9fcdb2b8101fc5e4e9275c579f0180484
+MISC metadata.xml 718 BLAKE2B a507fb09a57e6a8d4477c8176ed2b5eceac3fbc77b5ada3ae1098742c2bdf7346d1ebd7abd4142044fe320536c0b504ff80503ca8aa65a44573d8eaa07b1641c SHA512 6b0090912a2c6f7d8cd49eee4f0d28b47d58bffc80ec5c9bb56e8a5b1bd0341973bd0d26729c3e9f8486f590961646aba14efb7435558af7fcd1753aaa372625
diff --git a/sci-mathematics/palp/metadata.xml b/sci-mathematics/palp/metadata.xml
new file mode 100644
index 000000000000..b5439949c063
--- /dev/null
+++ b/sci-mathematics/palp/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="gitlab">stringstuwien/PALP</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/palp/palp-2.21.ebuild b/sci-mathematics/palp/palp-2.21.ebuild
new file mode 100644
index 000000000000..92c0a3cb307c
--- /dev/null
+++ b/sci-mathematics/palp/palp-2.21.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+# The arXiv version of the PDF manual
+MANUAL_PV=v1
+
+DESCRIPTION="A Package for Analyzing Lattice Polytopes (PALP)"
+HOMEPAGE="http://hep.itp.tuwien.ac.at/~kreuzer/CY/CYpalp.html
+ https://gitlab.com/stringstuwien/PALP"
+SRC_URI="https://gitlab.com/stringstuwien/PALP/-/archive/v${PV}/PALP-v${PV}.tar.bz2
+ https://arxiv.org/pdf/1205.4147${MANUAL_PV}.pdf -> ${PN}-manual-${MANUAL_PV}.pdf"
+S="${WORKDIR}/PALP-v${PV}"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The "mori.x" program pipes input to "Singular".
+RDEPEND="sci-mathematics/singular"
+
+src_compile() {
+ # Build the additional foo-Nd.x (for N=4,5,6,11) programs needed by
+ # SageMath.
+ emake CC=$(tc-getCC) all-dims
+}
+
+src_install() {
+ einstalldocs
+ newdoc "${DISTDIR}/${PN}-manual-${MANUAL_PV}.pdf" "manual-${MANUAL_PV}.pdf"
+
+ local PROGS=( class cws mori nef poly )
+ local DIMS=( 4 5 6 11 )
+ for prog in "${PROGS[@]}"; do
+ for N in "${DIMS[@]}"; do
+ dobin "${prog}-${N}d.x"
+ done
+ # The default "make" builds only one variant of each program,
+ # foo.x, corresponding to foo-6d.x. Users will expect those
+ # names, so we create a symlink from them to foo-6d.x.
+ dosym "${prog}-6d.x" "/usr/bin/${prog}.x"
+ done
+}