summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin19363 -> 19357 bytes
-rw-r--r--sci-mathematics/eclib/Manifest2
-rw-r--r--sci-mathematics/eclib/eclib-20240408.ebuild49
-rw-r--r--sci-mathematics/lrcalc/Manifest2
-rw-r--r--sci-mathematics/lrcalc/lrcalc-2.1.ebuild4
-rw-r--r--sci-mathematics/palp/Manifest2
-rw-r--r--sci-mathematics/palp/palp-2.21.ebuild2
-rw-r--r--sci-mathematics/planarity/Manifest2
-rw-r--r--sci-mathematics/planarity/planarity-3.0.2.0.ebuild4
-rw-r--r--sci-mathematics/primecount/Manifest2
-rw-r--r--sci-mathematics/primecount/primecount-7.13-r1.ebuild2
-rw-r--r--sci-mathematics/primesieve/Manifest2
-rw-r--r--sci-mathematics/primesieve/primesieve-12.3.ebuild2
13 files changed, 63 insertions, 12 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index ce7f9c8b966d..01ac93bfaf3e 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index f05cd1bd53cf..6a4e34a9ab55 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1,3 +1,5 @@
DIST eclib-20231212.tar.bz2 926463 BLAKE2B 8105ac4014f9e44545d1d1e1cd5e18e36e467131b57a04a02d7e4f2390b0b0f78d0bac60dfbc0403a6681816a64a6e81c8d6a198f83bef991f697c2756a6d048 SHA512 692aa6bc2a52cd9496700990172b5a807abbd3f8bf8e931de14c48a401d1d383f95fa5def68bbf9a1aee08dfabac608604c0fd6f8bb49b813e6c6c909a2f27a7
+DIST eclib-20240408.tar.bz2 918771 BLAKE2B e9f4a37973b40e73a111330800fcfebae91251613902b35ff29a45bdf3e7cd8cc49b061af121eff6aaa657d28b24b20ec00b77bad468504e545b3810852a50d2 SHA512 d93c724fa5816ce45a661d50000309e148fdbd0e287fbdbbf30bd6b3c6a7225846d90f11bc4d86c4b96111cbe8429b174e7d81ea0be1eef1a8acaa43287c09cf
EBUILD eclib-20231212.ebuild 1392 BLAKE2B 6cd0aa487c046e92e0c6e09620d5e010fcff89ce747949c8a5ba6e33aed4c00bca39188195e31ec768312bd1e1f7ca3ccd75f87db4f038f6ee557a4c526dab71 SHA512 d902ea983a3acaab8f5ce4ba59d72de7e24016ac7ca8aab38bc64efc97867cfb40ed4158919c3212bf66091a0efe47c92ab4950831f37d83642da835d793a673
+EBUILD eclib-20240408.ebuild 1400 BLAKE2B 974a16648861d3520bfa5aefe3aa6276c8d9de701b2ba4ae3d7cc6ce16709ea590928120cabfac18906fd0fea46d4da5474cef0c5d85d77636cfadfc01d5a9d0 SHA512 1f4135e0951eb8a83decd9b9f4103811c8f82d5b4b047dbb90122e3eb195b4a8942c4e9b40802f1d6037f8e8e64d152658185135a49969a06d53eed5907449e4
MISC metadata.xml 1089 BLAKE2B d10f9af5634478f0f13595abd10d9eefc437c27955cd3f504165beb4219e55c3997f16271148c1c2fbb5c9ae71e08665000836658bb954b83db06aeffa2b4098 SHA512 7111f3231464624d356611372934d0604fdd7a05c3531342a372979292a068dfa2edf49c4de5840cbf07b6f4819c22b8d87d54d7cacefb28ce0f53576d4620fd
diff --git a/sci-mathematics/eclib/eclib-20240408.ebuild b/sci-mathematics/eclib/eclib-20240408.ebuild
new file mode 100644
index 000000000000..a8b4b73b14eb
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20240408.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+# COPYING is GPL-2 but the file headers say "or ... any later version"
+# LGPL-2.1+ is for bundled GetOpt.cc
+LICENSE="GPL-2+ LGPL-2.1+"
+
+# Subslot is from the soname, (LT_CURRENT - LT_AGE) in configure.ac.
+# (But for now, see src_prepare below.)
+SLOT="0/12"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # LT_CURRENT was bumped to 12 in the 20230424 release but LT_AGE was
+ # left at two despite an interface being removed. Subsequent releases
+ # have propagated the off-by-two error. This isn't strictly necessary
+ # but it's nice to have the soname match the subslot.
+ sed -e 's/LT_AGE=3/LT_AGE=1/' -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-mathematics/lrcalc/Manifest b/sci-mathematics/lrcalc/Manifest
index 868dd8aa8279..4a92b7173e1c 100644
--- a/sci-mathematics/lrcalc/Manifest
+++ b/sci-mathematics/lrcalc/Manifest
@@ -2,5 +2,5 @@ AUX lrcalc-1.2-includes.patch 1939 BLAKE2B 37dc25d9219899cf9cd6268038715b927af29
DIST lrcalc-1.2.tar.gz 363120 BLAKE2B d3f652abfe38e81331dcbac7068d087b198445bf02dc5ccb5bcbd76b9bbc329687209e6ccf40ecd09f166e7d2da054edd0e5c2b18503d8e4d961ae4ad91b5152 SHA512 699f4c2ddabe5879542d5c11f3df3979a4e009ad37741711a70fb48b4a0d4a7969e5bb110adb63d4473f3c2b61d1efdb7228a6b74c5dd7e1b5aea8cf1d170fab
DIST lrcalc-2.1.tar.gz 425484 BLAKE2B 3c9d33942f44f8f6cf29e1da36ad5072b49ea3dd949f8c3e96a2fd55deec566828736ccc1da0ef32e528b8f4967bedbd46ca84f144e022a6916451c02befccc3 SHA512 76db29af51fb97e582d37b92a426cacf85fd61b8e7c2a70dc99dec23b396d62d996f0c66b5bbbd8b6928b46fa1186c9bb3c28aa91646cdccd38bd9b783af44d7
EBUILD lrcalc-1.2.ebuild 593 BLAKE2B 33456aaa57db869fe0cd00927fd0211d92e16fa217c96e3ccd45b44a5d7e46ef7dc60745374a0a121e68d21c0dcca52b5a5106a1d4e6536a8dafb652187ba746 SHA512 e4a3fdee7cad675379290ff92a70ed6eab3b010e152cab96e637592af5d4d2d0af0b3de7984d42c1c870b2205cfad49ecaf81666e077a50e74473f52221b545f
-EBUILD lrcalc-2.1.ebuild 541 BLAKE2B 111b36945f1082eb9ec873d2e808f74dd01bc6825867b13a645782d9cef19fb35d29427e2f672608ab71a6b6b57dd7417d04ed1764be0ab25d21a7cae54b5d92 SHA512 2c85be357925bb4ec8be96f1d57f785a86a9769c6762dc7a3b1050416c3200635bc7224d923f91bb4f4c4e99ecbdf441ff9958a68f31e04fd24857110dce6c3c
+EBUILD lrcalc-2.1.ebuild 548 BLAKE2B 16f6c9c4ce8c559c79d184e5bc6f2b8fc6269697f97f0516ea874f89f67eec702121b8adec8a822762e032350cd6eb9aa4e8ec7e4660f6907661db9a0eb8c3b9 SHA512 4076ab442e8b1f2d94112935c33086103981fd39a4fabe069dd0a9f7e8643a5fba9f396bb91a7bc58c046c1521ae36da95a9f1e5ec51b1803e6f4d27e263226d
MISC metadata.xml 865 BLAKE2B 59342f149f6ceb01b00073fa2714c268337bffe50d01b81ea8cf10b865d8c51112714932c92ed18373efc18d81ebf4d75446a0ec26b8cf5c6188eeffcdd79aab SHA512 3198cfa61428c86100f0e646f21460600afef73f83343799a903d6d43d1084eae08b135d74c302daf6d37eabb686d2413016c11b0b7c1e15a3907dd2b58f5146
diff --git a/sci-mathematics/lrcalc/lrcalc-2.1.ebuild b/sci-mathematics/lrcalc/lrcalc-2.1.ebuild
index b4cdd85c2350..28d4099dfbe3 100644
--- a/sci-mathematics/lrcalc/lrcalc-2.1.ebuild
+++ b/sci-mathematics/lrcalc/lrcalc-2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ SRC_URI="https://sites.math.rutgers.edu/~asbuch/lrcalc/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0/2"
-KEYWORDS="amd64 ~x86 ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 ~riscv ~x86 ~ppc-macos ~x64-macos"
IUSE="static-libs test"
RESTRICT="!test? ( test )"
diff --git a/sci-mathematics/palp/Manifest b/sci-mathematics/palp/Manifest
index 5e58108c226b..fa9bb3f6704e 100644
--- a/sci-mathematics/palp/Manifest
+++ b/sci-mathematics/palp/Manifest
@@ -1,4 +1,4 @@
DIST PALP-v2.21.tar.bz2 226701 BLAKE2B f2b57b916b011089b11e3e90e42653b243cbc999c4650b867f3a8c22f7a1bc883778d9678310fe4ecce497690b92c6cef71378ee2177da130b4b14c207f2383b SHA512 ab38469fbd78e0e5db437d892e44aec181810c3d5fbe67739081396ea97db2e47facf658335790b8ea6a7e422a090dde95d79413a7980d29a65db1854aa52dc2
DIST palp-manual-v1.pdf 517953 BLAKE2B 7243794d8bc62c58c8329a9db32958c1929feb27fae1779874a31c16c1e4fd641e4089d029402ad5188f385b4f20dd77fc82506990bcf252289b21ca1b084b58 SHA512 3cf9fe7038981a5c7aa9d73623e17dc7b944bd8b09b32964c196b2231c1621fbe6014e2b45b2b9db092adbdce27cbb72ea65ced5da0b1f010388fbbef1f534f7
-EBUILD palp-2.21.ebuild 1312 BLAKE2B 97bde917a407fb0744f5d7242dde9eacc967ef461c4d782874e85bebf30dc31ae662d210e75e1beaadd71b3e24b7e388867bd5bb92a656a29b1ba036041a2dae SHA512 4d936e24c422c5372a691cd753a087a582a0a4217ac5b6b999dc38e17bfef602f59e5d0ab6e29c85bd77af773c68b07c85bb620db59907841a4ecc2554dc0ac1
+EBUILD palp-2.21.ebuild 1319 BLAKE2B 4d06414d81a164e498a8ce11126beef846337c305ffc3cf4613c839471c14802d56ed096a6af0b7b40ede18dacbe030141aed7faa274f2a1f239cbec0bc41ee6 SHA512 f549f10a0a7372c5ceb6e3c0c6490491c8753e84e96bc1d5c6b7abab995929963fc465f91e2bc19af40670e5bf136fa0276bfde48969d80c0bda94ccd895499b
MISC metadata.xml 718 BLAKE2B a507fb09a57e6a8d4477c8176ed2b5eceac3fbc77b5ada3ae1098742c2bdf7346d1ebd7abd4142044fe320536c0b504ff80503ca8aa65a44573d8eaa07b1641c SHA512 6b0090912a2c6f7d8cd49eee4f0d28b47d58bffc80ec5c9bb56e8a5b1bd0341973bd0d26729c3e9f8486f590961646aba14efb7435558af7fcd1753aaa372625
diff --git a/sci-mathematics/palp/palp-2.21.ebuild b/sci-mathematics/palp/palp-2.21.ebuild
index 043002341a01..8ed9def3704f 100644
--- a/sci-mathematics/palp/palp-2.21.ebuild
+++ b/sci-mathematics/palp/palp-2.21.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://gitlab.com/stringstuwien/PALP/-/archive/v${PV}/PALP-v${PV}.tar.
S="${WORKDIR}/PALP-v${PV}"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64"
+KEYWORDS="amd64 ~riscv"
# The "mori.x" program pipes input to "Singular".
RDEPEND="sci-mathematics/singular"
diff --git a/sci-mathematics/planarity/Manifest b/sci-mathematics/planarity/Manifest
index ad39131953dd..32ffedb69e03 100644
--- a/sci-mathematics/planarity/Manifest
+++ b/sci-mathematics/planarity/Manifest
@@ -1,3 +1,3 @@
DIST planarity-3.0.2.0.tar.gz 462194 BLAKE2B 7927b04cb7c9839637fe13228da50cee581ef7fd7fdaaa9ff2dc62348ba10c7f42ba88a75801034fedc973cf86fca6396ba2fb0b1f71407d850b73b8a9fc4fd0 SHA512 dbbc97cd9cf0a5497fbca76f3b0741d3bcfca110c7022150750e73179a0a0441428c854479831395b8f6340d0554b1c0e7cf7eaa63f7fe40d2a59365488c7013
-EBUILD planarity-3.0.2.0.ebuild 504 BLAKE2B 28b677a802de2ff32e021c8d80272ac47b4c92eb1d7dffe4c3f67bcdc7485a74f8f11fe6aabdb4e724f94c1e129591730edded6f75097271ec2a2a23d7a38d2f SHA512 53d3bea711b5df67a90a8f70859c150c2023c2dcaa19c47e0980dab8a9d334dbd1dbe29df942e9909154f71c1c446834d49d285b050cf56ab3dc96567cb964ac
+EBUILD planarity-3.0.2.0.ebuild 511 BLAKE2B e70a69462a029d43ec941f6bc65dfd8350b883134d47a8d914eb5d95ba2b47fac1b8834f21bf23eeeffb9734270e8a0d4808c3175a9b61cc88f0e663f80104ce SHA512 5195526a82cbdb965834b0af8c6c706c116c7a3fd78a30aa61e2de17508f896bb7bfa1669c441f8bae03ee402bff9338ab2a172befebe227d487dcbecfdde344
MISC metadata.xml 809 BLAKE2B 6c3ad8e9bbbc3cfbd8c18183051153054b2ab7f4dd94e69c8f4f98a955001330d1e51e6b1da7f98a7ce29f7920b7a55a31624828a5aeaf7831ace0b4cf5dbec0 SHA512 5aa885d48f2d4626ed54a67abcc068186189e726ddb68bc889b6dc7d9aa09da30dbf7bb284020503d70bc94a25b5e16c907fe992862c2c2a6c344e2977e57f25
diff --git a/sci-mathematics/planarity/planarity-3.0.2.0.ebuild b/sci-mathematics/planarity/planarity-3.0.2.0.ebuild
index 11e65b5d56d1..499d8a63eeb7 100644
--- a/sci-mathematics/planarity/planarity-3.0.2.0.ebuild
+++ b/sci-mathematics/planarity/planarity-3.0.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,7 +10,7 @@ SRC_URI="https://github.com/graph-algorithms/edge-addition-planarity-suite/relea
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 ~riscv ~x86"
src_install() {
default
diff --git a/sci-mathematics/primecount/Manifest b/sci-mathematics/primecount/Manifest
index 48e146ff288a..890823d384e3 100644
--- a/sci-mathematics/primecount/Manifest
+++ b/sci-mathematics/primecount/Manifest
@@ -1,6 +1,6 @@
AUX primecount-7.13-gcc-15-buildfix.patch 1002 BLAKE2B 559087005bc7f476fb82a567337bec6ea100278d8b1f7a469da8789d90e95cafe7ba48ec1fdf8c72710646929d3c675f25874ccec6092116309d2be34fa130eb SHA512 1e4600453335eb861ee95947c0934f5b78fa683bd94a23782ddf137440bbe5fed0e9a16a3908f753c868d0da4435c7b2bb2b74bba8d952ffeb28c95904c840e2
DIST primecount-7.13.tar.gz 431676 BLAKE2B a02ba71af2b545f2a89e83018c3e9f2ab6ad5e567e5e72e3a0e85ccc132f1bc54b7dcc8b51ccdb1e727f6edcf050a856cee15e4180cc46a54fa8c5fe834d8cd8 SHA512 836c181e586a691708049d3ba04672e1dd4922160e17b3b03737ea55512186d3a529e003af08ff2e78f7bf7349cce0819c98144cfb89bd8208e4bad8124ae17b
DIST primecount-7.6.tar.gz 382074 BLAKE2B f665db8724b32b2f057db96fdd6421d7a996ed4bda7f43cd405e6c05b59abab8672407c41b6fafdd9c68dae3f51b65305112c0724c95ce3fdb33b9dbfaadfbff SHA512 643372d9a011dba8a49f21eabc00068b77a5ef5dc6d12e6b55230b97f14dc9d1d855bb7ad662beda548e4ff1396f1b06d473e2fe4b81e7dbe9926aaadc4da360
-EBUILD primecount-7.13-r1.ebuild 1271 BLAKE2B 090c8061f918ffd8cdda81f79590bdb259245121ec82ae17daf7a11b3a4bf921524b66dac1ad41658d859c01218df9b1b32b78ac545e7ff75846c28229df9752 SHA512 7503ccf23b771b4c0084a21ccc0c09cb1df5cb781dd58e8e06a0dddb16b6a2ac87b1205c3ec839e671c6f0975ade1815a580bc87f69a6d4389567e09df885074
+EBUILD primecount-7.13-r1.ebuild 1278 BLAKE2B 5e2656901d21e79053a151b7ef5ebbbdccc008b25d0f8034b02d6ed336ddc4e73af4f159564433015bcbf55a4c9183bbab904aa67de2b47ec69d492a5b713019 SHA512 d1af0d032a3924848a7300f17b331bd383c9dc958b98d8be23eeb1ba9a0e9a2390b6e9367b21a031d5cc117c55834ab87b7466be36540bfda60b2322c252447f
EBUILD primecount-7.6.ebuild 1284 BLAKE2B 899f461eb37ae77f62bdddd5650cf26d89b09c7b5ba043c786c1787adb24bc3ac1aef05c01800372895fea5d4c5303745917a86e29be361261839b8eef19e277 SHA512 299160fa362a1720ed11ae0bfad56e600a44c4323190d394e75b83fcb849e55a735b862fa9c234a8ac6b0319a435c578ea04eadbd44e47a2647b80d95372563e
MISC metadata.xml 674 BLAKE2B 2d8321166afee1e9d0a20723ae6849f17a7ef0d5d474dc3ec0b1650519b197ad5b1360641faa6985a60121501741a137812b8bcf03cd708766278a1b014615f7 SHA512 7a4fa0c1cae4880bdc230065c98ec46dfb5f1b1adae6ffa5eac275f6f04f38ce0c24042e62f5aac6117f9f816890244daec8fb1c920ec4b6a0a124385e5d7e33
diff --git a/sci-mathematics/primecount/primecount-7.13-r1.ebuild b/sci-mathematics/primecount/primecount-7.13-r1.ebuild
index 2408ad36320b..62113042f54e 100644
--- a/sci-mathematics/primecount/primecount-7.13-r1.ebuild
+++ b/sci-mathematics/primecount/primecount-7.13-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz ->
LICENSE="BSD-2"
SLOT="0/7" # subslot is first component of libprimecount.so version
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~riscv"
IUSE="+executable openmp test"
RESTRICT="!test? ( test )"
diff --git a/sci-mathematics/primesieve/Manifest b/sci-mathematics/primesieve/Manifest
index 402a3d56c117..df9164d57fbb 100644
--- a/sci-mathematics/primesieve/Manifest
+++ b/sci-mathematics/primesieve/Manifest
@@ -1,5 +1,5 @@
DIST primesieve-11.0.tar.gz 125086 BLAKE2B ac425b6435bc95efbfc3d7458b59719af390508db811e0a993a606397166771cfcb9c0269249341fb6f678aafa8bae4a89e7a914176f61a608e6ccdfd0cab22b SHA512 1be9ff9d07068cab1ca69315010238ab15e5ba3b674bd45e9a0e11d20418810ece05a8df3853796118193468ac2ac6e24391f82d6db9581658ce59ddabb5b7fc
DIST primesieve-12.3.tar.gz 140761 BLAKE2B d93aa8747d43850b9194172a2300942a685797c1aeb503240eb23cbbfe4b99281f3058a622d0e2359017e144ff8200dcecdd56922e16b46366d693b04eb1350a SHA512 b7bd74223ca9abe41de9f6a48102e6cfd1b1989fb291292c13f5c751a31f8df93e1faaadee318f169cfe81fa4dc4d5b0678fe7556f77043941d8ae749c6e8cc7
EBUILD primesieve-11.0.ebuild 1038 BLAKE2B 24f210bb5099c96234c0682bf634a3387ad33b8325b229497a93f7bcc77e04d604d08c579f4ad03414dc2669f648ebbf8ee0b1c6fbfe1c14c95fbeeb408e4120 SHA512 e8ef7324d624fbc1033081f443f3d241e631071869cf210ad4a5cf95ca879bda7f7dc29a308ddfedd775c60fbc5fd5d3fd1d85525ec76c06433439bcc8703331
-EBUILD primesieve-12.3.ebuild 1122 BLAKE2B 6f319a223f9440d473d09aae586d3db0ca8798596aa3082b74f8d9c3bac3fdc257914f7a961183a04f202f01a1f47b5a62f701946d3439d3478407e4ce248783 SHA512 a34b7e78759f13b96e868adf0df923dc7af3fbb20cbcd28d58f4f28a9d2d533442afa7a171268b6b2ad86b8eea0bff82f0a33448080ff1da358e035d39537cc7
+EBUILD primesieve-12.3.ebuild 1129 BLAKE2B ad789a6eecab521cf191a556da7a5c65c7247c58eb6461b533b16a32507cb72a2483e2dc627068610a823d77f13a190702c471d274036c3cc98b0581b83616db SHA512 84a244e06db884110fb45f1a4c6a0a7a9f49d1a7f07e88ec2d65370d036e766fc24fec13e467dc1744126f1b119be4299d907f25c33858a13d953e0d4db823ac
MISC metadata.xml 672 BLAKE2B e580c88061b6dcece5a34fde2cd13ce8c55264f3bac16fe3af6374df92d6280993452ebeea3d8446d9f8afcf7c1cb6927405c40e82a1c01a153d5060c77392fd SHA512 8ad3dd50c172ad3333d30a01b0e7ddb8f0f96b7666b61a0c6a1644e92abc49fa75f4f54c4c88eb72c2c8c7104d5e720d852bc7319fbc1a9569fcc5de85529b02
diff --git a/sci-mathematics/primesieve/primesieve-12.3.ebuild b/sci-mathematics/primesieve/primesieve-12.3.ebuild
index 580881f0c652..6d81d07c4184 100644
--- a/sci-mathematics/primesieve/primesieve-12.3.ebuild
+++ b/sci-mathematics/primesieve/primesieve-12.3.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://github.com/kimwalisch/primesieve"
SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0/12" # subslot is first component of libprimesieve.so version
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~riscv"
IUSE="doc +executable test"
RESTRICT="!test? ( test )"