summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin18993 -> 19001 bytes
-rw-r--r--sci-mathematics/eclib/Manifest2
-rw-r--r--sci-mathematics/eclib/eclib-20231212.ebuild49
3 files changed, 51 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index 652fe2f31885..711f8a46b897 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index b3424233c258..08174c2ae58b 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1,3 +1,5 @@
DIST eclib-20230424.tar.bz2 923074 BLAKE2B 00c314e54ff2ce37f3aa83b757c0f880aef563093ab33db5241dfeb1e78cfd21be4f6a5097965697d5b87aa1987da17bd47007a599717ebf39456717efa6ad2c SHA512 4c248c48fa563e53b9354f3822c4e95308320a809f2dcc3e116cba8a6f903b333e27b527da9a10dc8252052201c4fcf50d9747a75cf8438a98b9d3828eb3d9d9
+DIST eclib-20231212.tar.bz2 926463 BLAKE2B 8105ac4014f9e44545d1d1e1cd5e18e36e467131b57a04a02d7e4f2390b0b0f78d0bac60dfbc0403a6681816a64a6e81c8d6a198f83bef991f697c2756a6d048 SHA512 692aa6bc2a52cd9496700990172b5a807abbd3f8bf8e931de14c48a401d1d383f95fa5def68bbf9a1aee08dfabac608604c0fd6f8bb49b813e6c6c909a2f27a7
EBUILD eclib-20230424.ebuild 1232 BLAKE2B f7b144a7fc6125f5dea4fb532d65749c991f04e4bb8bb0262bbc8ad390a39f75649494b070a569a202fdcb913f7a4458ca31cdcb3c900d955baffdaa9c1bf4b2 SHA512 e2400d913e285d1d67e893ae61ef3cd735708a5a59cb6ef42a22a41f231d8df3a578c1cfc4c9327f41a10409d4c67cc56c8872213c709706698c6771b61681c9
+EBUILD eclib-20231212.ebuild 1393 BLAKE2B 43796d61a142bd12f0acaf145a09a1153e44cb7736507e3f600cebdcd171487fe4bc75e6df7b13a531fb6378df18ebcc187354ec7836d1d404e8e0d7f7de58dc SHA512 c88b2a1c108ce457e94931afc2fb000a2083531e709cfea33029d7308d987958479c8673f4f55a828b1e0ed00a8bc09501371a93d9f9b63fe7d2fba6a7871a97
MISC metadata.xml 1089 BLAKE2B d10f9af5634478f0f13595abd10d9eefc437c27955cd3f504165beb4219e55c3997f16271148c1c2fbb5c9ae71e08665000836658bb954b83db06aeffa2b4098 SHA512 7111f3231464624d356611372934d0604fdd7a05c3531342a372979292a068dfa2edf49c4de5840cbf07b6f4819c22b8d87d54d7cacefb28ce0f53576d4620fd
diff --git a/sci-mathematics/eclib/eclib-20231212.ebuild b/sci-mathematics/eclib/eclib-20231212.ebuild
new file mode 100644
index 000000000000..df7ada010cb3
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20231212.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+# COPYING is GPL-2 but the file headers say "or ... any later version"
+# LGPL-2.1+ is for bundled GetOpt.cc
+LICENSE="GPL-2+ LGPL-2.1+"
+
+# Subslot is from the soname, (LT_CURRENT - LT_AGE) in configure.ac.
+# (But for now, see src_prepare below.)
+SLOT="0/12"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # LT_CURRENT was bumped to 12 in the 20230424 release but LT_AGE was
+ # left at two despite an interface being removed. Subsequent releases
+ # have propagated the off-by-two error. This isn't strictly necessary
+ # but it's nice to have the soname match the subslot.
+ sed -e 's/LT_AGE=3/LT_AGE=1/' -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}