summaryrefslogtreecommitdiff
path: root/sci-mathematics/z3
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/z3')
-rw-r--r--sci-mathematics/z3/Manifest2
-rw-r--r--sci-mathematics/z3/z3-4.8.11b.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index 080df16d0c7f..d0c233f2064e 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,5 +1,7 @@
DIST z3-4.8.10.tar.gz 4731869 BLAKE2B 92487f71a0c8d961949dc23032d8fa3ff157fe7acc29b41d0d79326f8b59c60e19f43527cccf4e51872c0f0664598f9063876b04cc581f918aa48c37a13c4f3f SHA512 d2741d7ad3e1d5ee3fec92095b061a96a700c3327b2eb2090d4162bdcaeaebca8c072ef79c5daac1f6de3456165c2cc38e13f1045bc707779d1027b943837c5b
DIST z3-4.8.11.tar.gz 4799940 BLAKE2B 5478f9f45f2dc8ea5d2b781e79d886e77eed5ae034498b434dae349aa76f05836d8fd3134a08b381830b57acb3896ac51337d5bbe480dcce4770f2cd4fbee841 SHA512 ceab703d0413d0135e0f4e6c3ba2bb58d6a4823385edb0bf7ecc96949a3073b687d415a2674c86c9f876adb52823f98f9fbbc107d799ed756dc16292f9864894
+DIST z3-4.8.11b.tar.gz 4801435 BLAKE2B 903a04246fe4dedc96fda653fa9e3a57a80b951d20b992306bd07bc778cf0a94cf36fe4ed3f178bb26196a1ca294834c784a117fe906d52b82f874a43869d110 SHA512 dfcfc85209dd00aa5f07de0a7e7186a33442b72b94b05c01f53350b9281551be2a2c21ad5e7814bc2c52a3329be8df578e6be8c387cbfdc3a9d3bef0611d6613
EBUILD z3-4.8.10-r1.ebuild 2428 BLAKE2B dbcf484ac1b804abc88bc0dc7405e2c161f1d80259d972d2327c7f837bec3bee355efaa0d689fe5f490d09c0a509a2ee4be7fb38588518ca3f5db92997449e31 SHA512 3a48335f2cbb5d94a24c80793c4651f244c71645a869ee494ec83600aaaa3824a8198d71a32fe3c14c8f2df80c5b76ac321f41f6e04b5c4aab05851db65bf37c
EBUILD z3-4.8.11-r1.ebuild 2433 BLAKE2B 6289708b8c64f3aa62e98f659cc79bad7d9d189267e670d2543c45dc8b2fc60ee31b1a9950059f7a75ed2a470cf13d5a9dc5956259614985365de2aa6fd4418e SHA512 37db72f50f850d89bc9b540140d94d26a18358fda78afdd4cb95ba47b9ba3591c2afb50679acd722b776e8a9ff681688ab73899317d63d71c47687a8b8dd4d0e
+EBUILD z3-4.8.11b.ebuild 2434 BLAKE2B b2e68066debfd8269a84a38f38b62bcb27dac57a2c208f4025ffc06d423cbd78cb123dbf714a0042563d82c01e4374fd46a3989d9e756ba1f3731769a5304c6c SHA512 75d5212ecb38f38da01d765d0ff3c806cf25b04cd8d1d5d9bbcdf6c141f2069e7e9b5dc18a9fc6f5637ef297a7ad219d9e1bb7588a1d64af614630342fbbe168
MISC metadata.xml 616 BLAKE2B c35cac6f5810148c69a612d6b04ed4cacdbf066e61951ea1433336f14b2b058c4dd50530b547021007489122f5e94407b30641dc9ccf3b59a345e7a09e5fdd28 SHA512 eaf72a29601e96d5312120a1fc01a0b3dd2b7d8dbee70f6052e8ff7a7e07ae8b768d1417b7f4b523e755e5569092f2685bba77beaf3d7c455ccbd057cc9b670a
diff --git a/sci-mathematics/z3/z3-4.8.11b.ebuild b/sci-mathematics/z3/z3-4.8.11b.ebuild
new file mode 100644
index 000000000000..985b483904f9
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.8.11b.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake-multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+S=${WORKDIR}/z3-${P}
+
+SLOT="0/4.8"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc examples gmp isabelle java python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp:0=[cxx(+),${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.8 )"
+BDEPEND="
+ doc? ( app-doc/doxygen )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+ -DZ3_USE_LIB_GMP=$(usex gmp)
+ -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
+ -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
+ -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+ -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+ -DZ3_INCLUDE_GIT_DESCRIBE=OFF
+ -DZ3_INCLUDE_GIT_HASH=OFF
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build test-z3
+ set -- "${BUILD_DIR}"/test-z3 /a
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+multilib_src_install_all() {
+ dodoc README.md RELEASE_NOTES
+ use examples && dodoc -r examples
+ use python && python_optimize
+
+ if use isabelle; then
+ insinto /usr/share/Isabelle/contrib/${P}/etc
+ newins - settings <<-EOF
+ Z3_COMPONENT="\$COMPONENT"
+ Z3_HOME="${EPREFIX}/usr/bin"
+ Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+ Z3_REMOTE_SOLVER="z3"
+ Z3_VERSION="${PV}"
+ Z3_INSTALLED="yes"
+ Z3_NON_COMMERCIAL="yes"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [[ -f ${ROOT}/etc/isabelle/components ]]; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
+ contrib/${P}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new Isabelle component being installed during an upgrade.
+ sed -e "/contrib\/${P}/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ fi
+ fi
+ fi
+}