summaryrefslogtreecommitdiff
path: root/sci-mathematics/verifpal/verifpal-0.27.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/verifpal/verifpal-0.27.0.ebuild')
-rw-r--r--sci-mathematics/verifpal/verifpal-0.27.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/verifpal/verifpal-0.27.0.ebuild b/sci-mathematics/verifpal/verifpal-0.27.0.ebuild
new file mode 100644
index 000000000000..444b9284c857
--- /dev/null
+++ b/sci-mathematics/verifpal/verifpal-0.27.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Cryptographic protocol analysis for real-world protocols"
+HOMEPAGE="https://verifpal.com/
+ https://source.symbolic.software/verifpal/verifpal/"
+SRC_URI="
+ https://source.symbolic.software/${PN}/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.27.0-no-external-generate.patch )
+
+DOCS=( README.md examples )
+
+src_compile() {
+ local -a go_buildargs=(
+ -trimpath
+ -gcflags="-e"
+ -ldflags="-s -w"
+ )
+ ego build "${go_buildargs[@]}" ./cmd/verifpal
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe "${PN}"
+
+ einstalldocs
+}