summaryrefslogtreecommitdiff
path: root/sci-mathematics/unuran
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/unuran')
-rw-r--r--sci-mathematics/unuran/Manifest2
-rw-r--r--sci-mathematics/unuran/unuran-1.8.1.ebuild45
2 files changed, 25 insertions, 22 deletions
diff --git a/sci-mathematics/unuran/Manifest b/sci-mathematics/unuran/Manifest
index 1a5b1f317963..b33495b24b95 100644
--- a/sci-mathematics/unuran/Manifest
+++ b/sci-mathematics/unuran/Manifest
@@ -1,3 +1,3 @@
DIST unuran-1.8.1.tar.gz 4409911 BLAKE2B 2b036032deaeae70aa6ef58124fc88e9c167ae7952d04cba4b50181fff4249eff88c20bbb667c5702899bc863745b6991ae842da86f6bc592b6635dc310ec544 SHA512 4d98861914afe39065ec31ee837c0e21e0fb4f4667f559dee38a7a5c4e06f0d09bd550b20d06321d1f5fcd4799d482a9eebc66ac35f8cd7fff834f536d24854c
-EBUILD unuran-1.8.1.ebuild 998 BLAKE2B 2ea89ce75474449513f3c0e55c9f299d7d9d1eeaf2ff0eb8b1c6e2f76f32cfc135ed2b97cdfd7ebaddc5ca9fbe934ce379848b066f1a386cf387a0ad3acf3fbe SHA512 3de4820fb515dfa42c896da8fb2ba55def0b0fa23d4c7ca11b3e660f809b41ccc0f2ce174c005bcf42b281133fd4bfb45a048805dbe560b04d375da39f9be7b6
+EBUILD unuran-1.8.1.ebuild 1075 BLAKE2B 9b46dd7830ed35f33742528feeae0bde844ab5e62b3f55de474b16d6531af5460e96b547ed433dbe5b5a08f221ae7626d8076a8deab6f2af68f460104576cfda SHA512 646133d49d54ad0922a8f60389f93a08a5e526a05f3b32914ce6b4ea76d9a8cc367b228f2ff8e4575d23bb5a3321cde5f32a8d90e7159a0337aa6ff133505385
MISC metadata.xml 764 BLAKE2B fa69b69765aca99c96cfb65149eafa4c9f3c28368418747da5d285500c2416ebf2eb9ab4c575bdc07889a0036ff5d10fff8c906899893081650ce7522cfd0068 SHA512 9292cbfe62c3b99ce76ada16e9811bd0a6cbb1feee80cbcd83a36a60e9ae4e703ebf28a9bd728f3fc163b672fb17116693a98a19b6d4471dce69fce55c3cc6cf
diff --git a/sci-mathematics/unuran/unuran-1.8.1.ebuild b/sci-mathematics/unuran/unuran-1.8.1.ebuild
index f3fea32d662e..27d0f064189a 100644
--- a/sci-mathematics/unuran/unuran-1.8.1.ebuild
+++ b/sci-mathematics/unuran/unuran-1.8.1.ebuild
@@ -1,44 +1,47 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools-utils
+inherit out-of-source
DESCRIPTION="Universal Non-Uniform Random number generator"
HOMEPAGE="http://statmath.wu.ac.at/unuran/"
-SRC_URI="${HOMEPAGE}${P}.tar.gz"
+SRC_URI="http://statmath.wu.ac.at/unuran/${P}.tar.gz"
LICENSE="GPL-2"
-SLOT=0
+SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples gsl prng +rngstreams static-libs"
+IUSE="doc examples gsl prng +rngstreams"
DEPEND="
- gsl? ( sci-libs/gsl )
+ gsl? ( sci-libs/gsl:= )
prng? ( sci-mathematics/prng )
- rngstreams? ( sci-mathematics/rngstreams )"
+ rngstreams? ( sci-mathematics/rngstreams:= )"
RDEPEND="${DEPEND}"
-src_configure() {
+my_src_configure() {
local udefault=builtin
use rngstreams && udefault=rngstream
- local myeconfargs=(
- --enable-shared
- --with-urng-default=${udefault}
- $(use_with gsl urng-gsl)
- $(use_with prng urng-prng)
+ econf \
+ --enable-shared \
+ --disable-static \
+ --with-urng-default="${udefault}" \
+ $(use_with gsl urng-gsl) \
+ $(use_with prng urng-prng) \
$(use_with rngstreams urng-rngstream)
- )
- autotools-utils_src_configure
}
-src_install() {
- autotools-utils_src_install
+my_src_install_all() {
use doc && dodoc doc/${PN}.pdf
+ einstalldocs
+
if use examples; then
- rm examples/Makefile*
- insinto /usr/share/doc/${PF}
- doins -r examples
+ rm examples/Makefile* || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}