summaryrefslogtreecommitdiff
path: root/sci-mathematics/rkward/rkward-0.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/rkward/rkward-0.6.1.ebuild')
-rw-r--r--sci-mathematics/rkward/rkward-0.6.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/rkward/rkward-0.6.1.ebuild b/sci-mathematics/rkward/rkward-0.6.1.ebuild
new file mode 100644
index 000000000000..3b6c48e9bc05
--- /dev/null
+++ b/sci-mathematics/rkward/rkward-0.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KDE_DOC_DIRS="doc"
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="ca cs da de el es fr it lt pl tr zh_CN"
+
+inherit kde4-base
+
+DESCRIPTION="IDE for the R-project"
+HOMEPAGE="http://rkward.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rkward/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ dev-lang/R
+ $(add_kdeapps_dep katepart)"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # to have it compatible with R which had a bad R_HOME
+ unset R_HOME
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+ # avoid file collision with kate
+ rm "${ED}"/usr/share/apps/katepart/syntax/r.xml || die
+}