summaryrefslogtreecommitdiff
path: root/sci-mathematics/pymc3
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/pymc3')
-rw-r--r--sci-mathematics/pymc3/Manifest3
-rw-r--r--sci-mathematics/pymc3/metadata.xml19
-rw-r--r--sci-mathematics/pymc3/pymc3-3.1.ebuild60
3 files changed, 82 insertions, 0 deletions
diff --git a/sci-mathematics/pymc3/Manifest b/sci-mathematics/pymc3/Manifest
new file mode 100644
index 000000000000..248ae83ce813
--- /dev/null
+++ b/sci-mathematics/pymc3/Manifest
@@ -0,0 +1,3 @@
+DIST pymc3-3.1.tar.gz 34553828 SHA256 218e412408cd5f0bc0e6984404bcaadd32f80c4ef523ac8718c1f0c3fd8c4e28 SHA512 30799d9c1b670adbcf5cc1463029d71a87c7b917e83b1f6cb453d75553616da7173421e7ae6e31b332c85f8170daea735344ff83ba6605cf3b15cf79c5c4fb97 WHIRLPOOL bbc2a7304926bbebbb06c358503ed0ebec7de20c171ea1123eb8a978a4a5407ecb6f0cc6055cd22c6a58571315ad3e877b6317d18b8b02794b4d6c7bade10b79
+EBUILD pymc3-3.1.ebuild 1576 SHA256 5f855cf790c3c3c7cb45e5b6f4741f5950e124c5bec28456728522e797dd3787 SHA512 eb20c0a83771615edd6a6f8227e592d7b4c6fe44ace96559129bae11dd373c308f7ed78a86d477799c2b792934f214a2d80fe2943f31b57776810a5cc953d25e WHIRLPOOL cb566665112c14b055a1b9c3e4b8817dae251b0b0a924235928a25d2c8925d98535251d4094f1ebb4ffe09075f15c5dd6db242544c5a2f929225b2a27b4d827b
+MISC metadata.xml 740 SHA256 2c415f75f2c38e18554b1a5eb504b11d5d7f28fff5eaedb53b846d955c9e7e0b SHA512 c75ed4b57479fef93c4b667792cb284212f859532697c4d4876e2dc23ab13d2c470143d3236de03e741a0797049a12d3a7e2f0d2ae4f07b2cfb0b7943c78526d WHIRLPOOL 2170597440ef3d68ab9f3714812d33e48221ec0af22e12b77843e1341b6e64e2f24ca12901cb1bfc89c9287adc3c6cefa4a3783079afe0138f761a66e781108c
diff --git a/sci-mathematics/pymc3/metadata.xml b/sci-mathematics/pymc3/metadata.xml
new file mode 100644
index 000000000000..4476cda6eeea
--- /dev/null
+++ b/sci-mathematics/pymc3/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ PyMC3 is a Python package for Bayesian statistical modeling and
+ Probabilistic Machine Learning which focuses on advanced Markov
+ chain Monte Carlo and variational fitting algorithms. Its
+ flexibility and extensibility make it applicable to a large suite
+ of problems.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">pymc-devs/pymc3</remote-id>
+ <remote-id type="pypi">pymc3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/pymc3/pymc3-3.1.ebuild b/sci-mathematics/pymc3/pymc3-3.1.ebuild
new file mode 100644
index 000000000000..0361603fbe9f
--- /dev/null
+++ b/sci-mathematics/pymc3/pymc3-3.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+MYP=${P/_}
+S="${WORKDIR}/${MYP}"
+
+DESCRIPTION="Bayesian Modeling and Probabilistic Machine Learning in Python"
+HOMEPAGE="http://pymc-devs.github.io/pymc3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MYP}.tar.gz"
+
+SLOT=0
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="AFL-3.0"
+
+IUSE="test"
+
+RDEPEND="
+ <=dev-python/CommonMark-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/joblib-0.9[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP},lapack]
+ >=dev-python/matplotlib-1.5[${PYTHON_USEDEP}]
+ dev-python/nbsphinx[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.18[${PYTHON_USEDEP}]
+ >=dev-python/patsy-0.4[${PYTHON_USEDEP}]
+ >=dev-python/recommonmark-0.4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/theano-0.9[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.8.4[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.12[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=(CHANGELOG.md CONTRIBUTING.md RELEASE-NOTES.md
+ CONDUCT.md GOVERNANCE.md README.rst)
+
+python_prepare_all() {
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ echo 'backend: agg' > matplotlibrc || die
+ virtx esetup.py test
+}