summaryrefslogtreecommitdiff
path: root/sci-mathematics/picosat/picosat-965.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/picosat/picosat-965.ebuild')
-rw-r--r--sci-mathematics/picosat/picosat-965.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-mathematics/picosat/picosat-965.ebuild b/sci-mathematics/picosat/picosat-965.ebuild
new file mode 100644
index 000000000000..9803703a619b
--- /dev/null
+++ b/sci-mathematics/picosat/picosat-965.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="SAT solver with proof and core support"
+HOMEPAGE="http://fmv.jku.at/picosat/"
+SRC_URI="http://fmv.jku.at/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.in.patch )
+
+src_configure() {
+ CC="$(tc-getCC)" sh ./configure.sh --shared --trace || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -fPIC"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe picomus picomcs picosat picogcnf
+
+ insinto /usr/share
+ newins VERSION picosat.version
+
+ dolib.so libpicosat.so
+ doheader picosat.h
+
+ dodoc NEWS README
+}