summaryrefslogtreecommitdiff
path: root/sci-mathematics/otter/otter-3.3-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/otter/otter-3.3-r3.ebuild')
-rw-r--r--sci-mathematics/otter/otter-3.3-r3.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sci-mathematics/otter/otter-3.3-r3.ebuild b/sci-mathematics/otter/otter-3.3-r3.ebuild
index eec8a1d25164..6eb0dc06c302 100644
--- a/sci-mathematics/otter/otter-3.3-r3.ebuild
+++ b/sci-mathematics/otter/otter-3.3-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="An Automated Deduction System"
HOMEPAGE="http://www.cs.unm.edu/~mccune/otter/"
@@ -12,7 +12,6 @@ SRC_URI="http://www.cs.unm.edu/~mccune/otter/${P}.tar.gz"
LICENSE="otter"
SLOT="0"
KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
RDEPEND="
x11-libs/libX11
@@ -25,6 +24,10 @@ PATCHES=(
"${FILESDIR}"/${P}-gold.patch
)
+src_configure() {
+ append-cflags -fcommon
+}
+
src_compile() {
tc-export CC