summaryrefslogtreecommitdiff
path: root/sci-mathematics/mlpy
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/mlpy')
-rw-r--r--sci-mathematics/mlpy/Manifest5
-rw-r--r--sci-mathematics/mlpy/metadata.xml17
-rw-r--r--sci-mathematics/mlpy/mlpy-3.5.0.ebuild34
3 files changed, 56 insertions, 0 deletions
diff --git a/sci-mathematics/mlpy/Manifest b/sci-mathematics/mlpy/Manifest
new file mode 100644
index 000000000000..3cdb494ddc60
--- /dev/null
+++ b/sci-mathematics/mlpy/Manifest
@@ -0,0 +1,5 @@
+DIST mlpy-3.5.0.tar.gz 1961206 SHA256 344fa75fbf9f76af72f6a346d5309613defc4d244bac13c218e509a51d68bf6a SHA512 b6b3cf6e1d47fe58d68da81752ce9324e78a97c9fc341c93db7b2ea0c5d1730fae9535b69671fda13cb012ab0173951768c1601f2b4ad678a6065c018b34eb0f WHIRLPOOL 531cf00f31e8abb72d4d882aa41379d1214f17f04c028922f084756059d471c3e0ddead82d089262e2855d843e8e8e96233bc06937870e6f1f589906889a756f
+EBUILD mlpy-3.5.0.ebuild 760 SHA256 cbea220884a5beaf1eda85db31bc31ea9ace27f001de6b21d97c47abad36363e SHA512 7c64b4d3e899a1fae30c71a14968d7593584d78b0d3241b3a58aaff1b2ec280d998c1600e6ab0e2a7bf95d2915215a2e7028f46cbfd1a1393975ea17f15db057 WHIRLPOOL 80a641d5280b5add8703f6cfc9a945b8ef06408bb0568b8e38621e65c7bfb1101cdc090afa62eb33ca1d563f1a156c97660a7f10a2931d7bb86fa4dc9dd93698
+MISC ChangeLog 2705 SHA256 092ce2a9a15a41cdff480febb6f193d752a2b8a61042cfaab237bdb1036e6ae3 SHA512 7c0f24bca18b59e41f88b7cc2ed54810f49c7754f6700fdd501f9782511c5564c033bc87776b01b8717d1e7c783187f009033698aaa9ebada069ef024426f1af WHIRLPOOL fb086ffb5f62ff2bab4390c1bec1b53295c04d4e7175fcc5fb7b80141a3076c7d9bd906919933b762a5c257c934af6cd7d054b130eb2f03f843531c2eaa5462f
+MISC ChangeLog-2015 834 SHA256 74db66bfd9f0b89facd9736cd7c06c7641441f3b2c7f0779dea5346129673866 SHA512 5df885df4867b790ab2731a79ad5fdf9a3ba5cd5215e6ee8980cb36d5ce3ed14702cb926d5411b3e079f23aeff6493cd07362b3e538f2269e5273c44c312f4ea WHIRLPOOL c1236ed8a7634f9dbe5453e5271782e23d99cf3418db5f7e90e127d0c7a5981356024f7a95578f0da020b5163fd15efeb03635e256259fb2fad65ff136cc3333
+MISC metadata.xml 636 SHA256 e1263527ab9639d5fb135a6101026fca6ed008a4bf300b949280ed258708e923 SHA512 19452defd96c62d603f0f99cc2fb1359159c91ed7489e2f7d0e7b4d4e290dc9f74d3124b1cf75fa631bd0536df5fb39023efa534c3f6ea4de3e340363d7d8bfa WHIRLPOOL 11f2a615c392bc6feca1babca18cf9e1134edd9a591a7597cd3508b0910ea7197cf61354edb2fd7f151891c805b4fe4c5ed97007239b66af584679fc95474393
diff --git a/sci-mathematics/mlpy/metadata.xml b/sci-mathematics/mlpy/metadata.xml
new file mode 100644
index 000000000000..a878c2ab46ae
--- /dev/null
+++ b/sci-mathematics/mlpy/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ mlpy provides a wide range of state-of-the-art machine learning
+ methods for supervised and unsupervised problems and it is aimed at
+ finding a reasonable compromise among modularity, maintainability,
+ reproducibility, usability and efficiency.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">mlpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/mlpy/mlpy-3.5.0.ebuild b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
new file mode 100644
index 000000000000..c25423df83a5
--- /dev/null
+++ b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="High-performance Python library for predictive modeling"
+HOMEPAGE="https://mlpy.fbk.eu/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ >=sci-libs/gsl-1.11
+ >=dev-python/numpy-1.3[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ pushd docs 2>/dev/null || die
+ emake html
+ dohtml -r build/html/*
+ popd 2>/dev/null || die
+ fi
+}