summaryrefslogtreecommitdiff
path: root/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild')
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
index 62d2aabe95ee..7ed81f19115a 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://gforge.inria.fr/frs/download.php/file/36224/${P}.tar.gz"
LICENSE="GPL-3 LGPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="amd64 x86 ~ppc-macos ~x64-macos ~x86-macos"
IUSE="+custom-tune openmp static-libs cpu_flags_x86_sse2"
DEPEND="dev-libs/gmp:="
@@ -26,6 +26,17 @@ pkg_pretend() {
use openmp && tc-check-openmp
}
+src_compile() {
+ default
+ if use custom-tune; then
+ # One "emake" was needed to build the library. Now we can find
+ # the best set of parameters, and then run "emake" one more time
+ # to rebuild the library with the custom parameters. See the
+ # project's README or INSTALL-ecm. The build targets don't depend
+ # on ecm-params.h, so we need to "make clean" to force a rebuild.
+ emake ecm-params && emake clean && emake
+ fi
+}
src_configure() {
econf \
--enable-shared \