summaryrefslogtreecommitdiff
path: root/sci-mathematics/giac/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/giac/files')
-rw-r--r--sci-mathematics/giac/files/giac-1.9.0.67-glibcxx-assertions.patch30
-rw-r--r--sci-mathematics/giac/files/giac-1.9.0.93-glibcxx-assertions.patch31
-rw-r--r--sci-mathematics/giac/files/giac-1.9.0.93-no-fltk-buildfix.patch60
3 files changed, 91 insertions, 30 deletions
diff --git a/sci-mathematics/giac/files/giac-1.9.0.67-glibcxx-assertions.patch b/sci-mathematics/giac/files/giac-1.9.0.67-glibcxx-assertions.patch
deleted file mode 100644
index dcdcfb5a728e..000000000000
--- a/sci-mathematics/giac/files/giac-1.9.0.67-glibcxx-assertions.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 8fa2b53ee0db1827a4ddd88a7e754a7b1d91ca2c Mon Sep 17 00:00:00 2001
-From: Michael Orlitzky <michael@orlitzky.com>
-Date: Fri, 25 Aug 2023 20:33:31 -0400
-Subject: [PATCH 1/1] configure.ac: delete _GLIBCXX_ASSERTIONS override
-
-This was added upstream when it was pointed out that the codebase
-contains undefined behavior that triggers glibcxx's assertions.
-Disabling the assertions without fixing the undefined behavior is not
-a satisfactory solution, so we drop the override.
----
- configure.ac | 4 ----
- 1 file changed, 4 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index d66c3e1..6fef28b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -45,10 +45,6 @@ GINAC_STD_CXX_HEADERS
- AC_CHECK_HEADERS(regex)
- AC_CHECK_FUNCS(tgammaf)
-
--dnl CXXFLAGS="$CXXFLAGS -std=c++0x"
--dnl avoid "security" checks for vectors
--CXXFLAGS="$CXXFLAGS -U_GLIBCXX_ASSERTIONS"
--
- dnl Define DOUBLEVAL if bigendian
- if test "x$ac_cv_c_bigendian" = "xyes"; then
- CXXFLAGS="$CXXFLAGS -DDOUBLEVAL"
---
-2.41.0
diff --git a/sci-mathematics/giac/files/giac-1.9.0.93-glibcxx-assertions.patch b/sci-mathematics/giac/files/giac-1.9.0.93-glibcxx-assertions.patch
new file mode 100644
index 000000000000..d11eaf9ab01d
--- /dev/null
+++ b/sci-mathematics/giac/files/giac-1.9.0.93-glibcxx-assertions.patch
@@ -0,0 +1,31 @@
+From 77a08fddd1687e245f9f7567376f858607a76db0 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Mon, 4 Mar 2024 10:58:21 -0500
+Subject: [PATCH] configure.ac: delete _GLIBCXX_ASSERTIONS override
+
+This was added upstream when it was pointed out that the codebase
+contains undefined behavior that triggers glibcxx's assertions.
+Disabling the assertions without fixing the undefined behavior is not
+a satisfactory solution, so we drop the override.
+---
+ configure.ac | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 62b63fb..3e4909f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -46,9 +46,8 @@ AC_CHECK_HEADERS(regex)
+ AC_CHECK_FUNCS(tgammaf)
+
+ dnl CXXFLAGS="$CXXFLAGS -std=c++0x"
+-dnl avoid "security" checks for vectors
+ dnl -DUSE_OBJET_BIDON added because xcas::localisation() does not load locales correctly for modules loaded before main() is executed
+-CXXFLAGS="$CXXFLAGS -U_GLIBCXX_ASSERTIONS -DUSE_OBJET_BIDON"
++CXXFLAGS="$CXXFLAGS -DUSE_OBJET_BIDON"
+
+ dnl Define DOUBLEVAL if bigendian
+ if test "x$ac_cv_c_bigendian" = "xyes"; then
+--
+2.43.0
+
diff --git a/sci-mathematics/giac/files/giac-1.9.0.93-no-fltk-buildfix.patch b/sci-mathematics/giac/files/giac-1.9.0.93-no-fltk-buildfix.patch
new file mode 100644
index 000000000000..970ba22c6cca
--- /dev/null
+++ b/sci-mathematics/giac/files/giac-1.9.0.93-no-fltk-buildfix.patch
@@ -0,0 +1,60 @@
+diff --git a/src/Editeur.cc b/src/Editeur.cc
+index d69dce2..f7725bb 100644
+--- a/src/Editeur.cc
++++ b/src/Editeur.cc
+@@ -3,7 +3,6 @@
+ #include "Input.h"
+ #include "Tableur.h"
+ #include "Python.h"
+-Fl_Tabs * xcas_main_tab=0;
+ #ifdef HAVE_LIBMICROPYTHON
+ extern "C" int mp_token(const char * line);
+ #endif
+@@ -27,6 +26,7 @@ extern "C" int mp_token(const char * line);
+
+
+ #ifdef HAVE_LIBFLTK
++Fl_Tabs * xcas_main_tab=0;
+ #include <FL/fl_ask.H>
+ #include <FL/fl_ask.H>
+ #include <FL/Fl_Return_Button.H>
+diff --git a/src/icas.cc b/src/icas.cc
+index a5e3711..44ec905 100644
+--- a/src/icas.cc
++++ b/src/icas.cc
+@@ -2166,11 +2166,13 @@ int main(int ARGC, char *ARGV[]){
+ printf("%s\n","Running ./xcas");
+ continue;
+ }
++#ifdef HAVE_LIBFLTK
+ if (s=="xcas"){
+ giac::gen ge; std::string filename;
+ xcas::fltk_view(0,ge,"session.xws",filename,5,contextptr);
+ continue;
+ }
++#endif
+ if (s=="giac"){
+ python_compat(python_compat(contextptr)&3,contextptr);
+ printf("%s\n","Switching to giac interpreter");
+@@ -2251,7 +2253,9 @@ int main(int ARGC, char *ARGV[]){
+ #else
+ start=clock();
+ #endif
++#ifdef HAVE_LIBFLTK
+ xcas::icas_eval(gq,ge,reading_file,filename,contextptr);
++#endif
+ #ifdef __APPLE_
+ startc=clock()-startc;
+ #endif
+@@ -2265,9 +2269,11 @@ int main(int ARGC, char *ARGV[]){
+ // 2-d plot?
+ int graph_output=graph_output_type(ge);
+ if (reading_file>=2 || graph_output || (giac::ckmatrix(ge,true) &&ge.subtype==giac::_SPREAD__VECT) ){
++#ifdef HAVE_LIBFLTK
+ if (xcas::fltk_view(gq,ge,"",filename,reading_file,contextptr))
+ cout << "Done";
+ else
++#endif
+ cout << "Plot cancelled or unable to plot";
+ }
+ else {