summaryrefslogtreecommitdiff
path: root/sci-mathematics/gfan/gfan-0.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/gfan/gfan-0.6.2.ebuild')
-rw-r--r--sci-mathematics/gfan/gfan-0.6.2.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sci-mathematics/gfan/gfan-0.6.2.ebuild b/sci-mathematics/gfan/gfan-0.6.2.ebuild
index a75c9f76f0f7..44e051550034 100644
--- a/sci-mathematics/gfan/gfan-0.6.2.ebuild
+++ b/sci-mathematics/gfan/gfan-0.6.2.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://users-math.au.dk/~jensen/software/${PN}/${PN}${PV}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
IUSE="doc"
BDEPEND="doc? ( virtual/latex-base )"
@@ -29,9 +29,20 @@ PATCHES=(
pkg_setup() {
tc-export CC CXX
+
+ # This should really go in cppflags, but that doesn't work with
+ # gfan's hand-written Makefile.
append-cxxflags -DNOCDDPREFIX
}
+src_prepare() {
+ default
+
+ # This test hangs on x86, bug 717112.
+ rm -r testsuite/0602ResultantFanProjection || \
+ die "unable to disable test 0602ResultantFanProjection"
+}
+
src_configure() {
# The upstream Makefile says that GCC produces bad code with -O3.
replace-flags "-O3" "-O2"