summaryrefslogtreecommitdiff
path: root/sci-mathematics/genius
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/genius')
-rw-r--r--sci-mathematics/genius/Manifest6
-rw-r--r--sci-mathematics/genius/genius-1.0.21.ebuild55
-rw-r--r--sci-mathematics/genius/metadata.xml22
3 files changed, 83 insertions, 0 deletions
diff --git a/sci-mathematics/genius/Manifest b/sci-mathematics/genius/Manifest
new file mode 100644
index 000000000000..f189e3b236c6
--- /dev/null
+++ b/sci-mathematics/genius/Manifest
@@ -0,0 +1,6 @@
+DIST genius-1.0.21.tar.xz 2539784 SHA256 f8c06a4d0aefc1bc934e993aaf8f913451d06c2bae378da1071c3bacf39ed934 SHA512 d4f5e80e1cc6216d7f460f7de86d232566eeb30fec90b93b2e6ccb8d2d0c14aaadf9b969c9a4f940a036e246f085edd02298c769504b620d2eb97ef2a3a852da WHIRLPOOL 52337e85a758d7c1f7b6551c0aec29236bef2f1fbd4f48e29142f8e69c513a7b8ddd79084421cdce79d90fe7a00da4c4d0a9b800ad75f9716cb3108da73b10fd
+DIST genius-reference.pdf 1024944 SHA256 79011ae33ff781507185898ba76b156699061eda78ed16e15aa02195c896ee4b SHA512 04af3870104d2320b1d4b345d74d713a0dfcdf8a228002506508f437659b3ef6037ead0b1f6b37cc335692150750b58c4007fdaaddd9540233474ccd10dac285 WHIRLPOOL 301302145d43843ddd749ab33612438d360462c9d3daa12d7050d9ca6da82bdea3ef53b917989d0c518327780b147a9f74e407f555a62dcdbe0f0c2ef864fa88
+EBUILD genius-1.0.21.ebuild 1104 SHA256 0dd6c0251fea868b69d20e813534790544de1bd34b051218fa1d267af17d358a SHA512 de3c3f51b6117b19c602a8c50a6091c395cbdfb2e38fb65c88cbc5f82138fc4572f2389079b7f59e0d1e580097ce058bc525253bc1721017dc58a934f0a7dcd3 WHIRLPOOL b94ed79d827d3d3e3de4ca93d41d0e09ab5230270adb978c4bc0b5577549163797ca8c7bd84d586ee50619a0ba69a696d8081c55466e259a70974dc61b4c6df3
+MISC ChangeLog 3213 SHA256 0bebb9cc9c6b308ddc920f2bd42f923ba2ca5aa746bdded790921d31f407c2d3 SHA512 45f2d726ebd61f5a58fc810b3922f7e818c61ca153842ae2d742744fcf94f568b8fe622264abcf6392b7c69d4effe5f5634eb54a9dfad7d45f91abe0d14aebe0 WHIRLPOOL d468d2af2684fdcddb2955349df5ad152f1f8c3ada72ffdf655c1e4e34d7c4c3e29307260f78e34e9c3c30c5df866734e4861554bf6d624429684b066dc1e464
+MISC ChangeLog-2015 1907 SHA256 42442e550f3387ef3ae1349f984e94f24e34d3c4da7270ac2ea66f7422b35ff6 SHA512 41cc63bb3be5d5a02fe27c120b17aa0d66656fa4101985037fc90d976690ffcd4264dda218df02d576135e932a5560a1253bb4a996c3d62cd3c6311f945c3018 WHIRLPOOL 0f8c29afdadfc11bd3472bc385353138bbdf34f806a8f6592cd9c31adbd2f4ce3851711eab47b2ec2582a4686253af7569af58b23f4a4b101908d7a2cd03ba38
+MISC metadata.xml 934 SHA256 9ea33121ff11b87b046a6ff44dc1e30d54bc927bf9a6afe05408dd2b3609e927 SHA512 c0262f8a5e3615cf75e0996dcb5339144a897003020172c9dc49d57459c4b8bba72ecf921836e081f4e4b42c62ffd06654e5e2270c7d58487feba9be8b20b215 WHIRLPOOL 9d0fb7ceafa1ff92100c3ccf9387a71e33d83af9d2b557d498e426e4289bc4f181afeaa1ecde5b39817ea5de1136ef2a72aa8133cf384a0d0c45115dcc9f0d62
diff --git a/sci-mathematics/genius/genius-1.0.21.ebuild b/sci-mathematics/genius/genius-1.0.21.ebuild
new file mode 100644
index 000000000000..06833d14df83
--- /dev/null
+++ b/sci-mathematics/genius/genius-1.0.21.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Genius Mathematics Tool and the GEL Language"
+HOMEPAGE="http://www.jirka.org/genius.html"
+SRC_URI="${SRC_URI}
+ doc? ( http://www.jirka.org/${PN}-reference.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gnome nls"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ dev-libs/popt
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ gnome? (
+ x11-libs/gtk+:2
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/libglade:2.0
+ x11-libs/gtksourceview:2.0
+ x11-libs/vte:0 )
+"
+DEPEND="${RDEPEND}
+ app-text/rarian
+ dev-util/gtk-update-icon-cache
+ dev-util/intltool
+ || ( sys-devel/bison dev-util/yacc )
+ sys-devel/flex
+ app-text/gnome-doc-utils
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable gnome) \
+ $(use_enable nls) \
+ --disable-extra-gcc-optimization \
+ --disable-static
+}
+
+src_install() {
+ use doc && DOCS+=" ${DISTDIR}/${PN}-reference.pdf"
+ gnome2_src_install
+}
diff --git a/sci-mathematics/genius/metadata.xml b/sci-mathematics/genius/metadata.xml
new file mode 100644
index 000000000000..2d756ba64d95
--- /dev/null
+++ b/sci-mathematics/genius/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>Genius is a calculator program which can work
+ with arbitrary precision integers, multiple precision floats,
+ rational numbers, complex numbers, linear algebra, number theory,
+ numerical calculus, statistics, numerical equation solving,
+ combinatorics, elementary functions, modular arithmetic.
+ It has a programming language with automatic typing.
+ It can do various 2D and 3D plots, with possibility
+ to export to eps or png. Genius has a GUI IDE.
+ It can output matrices in LaTeX, Troff (eqn) or MathML.
+ </longdescription>
+</pkgmetadata>