summaryrefslogtreecommitdiff
path: root/sci-mathematics/fann
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/fann')
-rw-r--r--sci-mathematics/fann/Manifest7
-rw-r--r--sci-mathematics/fann/fann-2.2.0-r1.ebuild39
-rw-r--r--sci-mathematics/fann/fann-9999.ebuild28
-rw-r--r--sci-mathematics/fann/files/fann-2.2.0-examples.patch23
-rw-r--r--sci-mathematics/fann/metadata.xml19
5 files changed, 116 insertions, 0 deletions
diff --git a/sci-mathematics/fann/Manifest b/sci-mathematics/fann/Manifest
new file mode 100644
index 000000000000..530c208afae1
--- /dev/null
+++ b/sci-mathematics/fann/Manifest
@@ -0,0 +1,7 @@
+AUX fann-2.2.0-examples.patch 941 SHA256 c4fecc90a3e001a2db726a7e86531711f509d915724c8dd96acee87d84adbcf7 SHA512 617c43352912b965d0c7ef445aecdb15a5148260e3f41c1b0e8cdd5abb0246e6ad0338c74b75c690fbc63175692578dcc596612108c3b9804694cecace046b34 WHIRLPOOL 3dbc3c7ab92b111a82c50dd7555e5193725233b53a4db34d572aaf2d60e451d26f5c18bceb572b2088dede192e11441d74c41212589f918015dea6fd76b47581
+DIST FANN-2.2.0-Source.zip 2285087 SHA256 434b85fce60701c4e0066c442d60110d8e649f278e4edb814f0c0e7a1e0929fd SHA512 c486694aac53cf91a83f8b68d9020fc74ca2bea9416c9d06b6dc8f53d30a2261bd00212e3d439adef9fbdd82532056f7c1afed793f5574c2d6191d84d26fb5c2 WHIRLPOOL 12f6ccaa425bfcd495d47e5a20ad6549a53dba984a9f8f3f0baec078b420a56c8cced6926702604142e543a8920cb30dc57cfa80888c14cfc86a534d6f8cd6a3
+EBUILD fann-2.2.0-r1.ebuild 769 SHA256 81e28c33a7d0a245604f0c8beaaa9c1e5af6985b783c076e81dd8f705faf9f3d SHA512 2f620edb4c345f50b1344bf7fb47d9471e6daae9d7c4c6f2fa9ef60f61c26bb3d62d7cd9b20a23f8816c3bd6a18b466eb2c8ac070adf75371c8772d389b94738 WHIRLPOOL 7d158fc3fdfc43f0d2b1ad3a2b5d7202493c60673a4dd530c771916f37871588a2d1d0b2d2706d6cb6a8348a6b142e89d418bcfd0e76e897b1084298fa4207be
+EBUILD fann-9999.ebuild 657 SHA256 b6351709122eb4d11a8b00ed5c65dd35977fd02f1cc85e83869bdf918c16afc2 SHA512 5c2002f43aa598135999993929a09584b048d9d2f0d5e2b695a7e5e1d54b0f84e7e92ca4fcec91831f202ab0f40231cfdcd3666517d2d0634e67be393611876b WHIRLPOOL 434b54e69e49053de801cbfca207514089bad445944de5ed9e5b855f34c40e144ab2c993c6724b855f22ab01f82631e63bffc828fa232e5068f6ae57baa55945
+MISC ChangeLog 3406 SHA256 f357daa686edc4c94989ba931e8c2a12e24adad2b603e2b6fafdbc3f3a5e958b SHA512 4a907256b11d9da0f6c6c5f60d704d50f7538831d2cb59ce6040158c025784ab70782b9cc00259b2278623d83fb4136ae4be3333d6ffc0ae55bbf09ae3ef706e WHIRLPOOL b61b4b77a0fbd1368f08a4a93594480e51f365c7430feb363344df4e6415b9de37af177586b9fc860bfa962b080f1dcfa7073499072a10a5d06d4a46bc78b02b
+MISC ChangeLog-2015 3595 SHA256 35f1c1926c937834b379a0ecc3bc84c5461a0a77d4712e9ff88408cacde73a93 SHA512 753980e2b0a0028876e5203e0be6197623b40b33a272a2e8ca3ed702b868ecdcba88599bc3c92a965278e52db45ad499c4249f5f762428966d831e6d46b4e051 WHIRLPOOL 00198c4f2c63e915848b24b409a8442ce077c596e765867946410755e350101d062120b7daa33aba39f13453402e2dba94f43ce5714c9215ca4a1cf38a6fc4a4
+MISC metadata.xml 841 SHA256 a8fdc1801f3a55f05b17dc7a13a1cb270f4736a961a4aa6e998ba0904b7e11fb SHA512 4cca56af735bab9710d8e62891c749e990813eb99bc28c01fec63de8038fecd89bbd7b331841a530aaf1b61cf3b77f7995a7006cebe158ad197527ae2fea7ef6 WHIRLPOOL 3f314db0bcdb81ade32e2afec0b6bdfc30c98733fe339c3f1de10d0759f0fe2d9e6f6f1e32af93ccf718e01f224a60917657ffebc494f98392b3768216db7fe8
diff --git a/sci-mathematics/fann/fann-2.2.0-r1.ebuild b/sci-mathematics/fann/fann-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..614220457998
--- /dev/null
+++ b/sci-mathematics/fann/fann-2.2.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+MY_P=FANN-${PV}-Source
+
+DESCRIPTION="Fast Artificial Neural Network Library"
+HOMEPAGE="http://leenissen.dk/fann/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/${P}-examples.patch" )
+
+src_test() {
+ cd examples || die
+ emake CFLAGS="${CFLAGS} -I../src/include -L${BUILD_DIR}/src"
+ LD_LIBRARY_PATH="${BUILD_DIR}/src" emake runtest
+ emake clean
+}
+
+src_install() {
+ cmake-multilib_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-mathematics/fann/fann-9999.ebuild b/sci-mathematics/fann/fann-9999.ebuild
new file mode 100644
index 000000000000..ffe0d8b9bb2d
--- /dev/null
+++ b/sci-mathematics/fann/fann-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib git-r3
+
+DESCRIPTION="Fast Artificial Neural Network Library"
+HOMEPAGE="http://leenissen.dk/fann/"
+EGIT_REPO_URI="https://github.com/libfann/fann"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="examples"
+
+src_test() {
+ cd examples || die 'fails to enter examples directory'
+ LD_LIBRARY_PATH="${BUILD_DIR}/src" GCC="$(tc-getCC) ${CFLAGS} -I../src/include -L${BUILD_DIR}/src" emake -e runtest
+ emake clean
+}
+
+src_install() {
+ cmake-multilib_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-mathematics/fann/files/fann-2.2.0-examples.patch b/sci-mathematics/fann/files/fann-2.2.0-examples.patch
new file mode 100644
index 000000000000..189e6936e457
--- /dev/null
+++ b/sci-mathematics/fann/files/fann-2.2.0-examples.patch
@@ -0,0 +1,23 @@
+--- a/examples/Makefile.orig 2012-01-24 05:31:40.000000000 +0000
++++ b/examples/Makefile 2012-05-08 19:00:08.000000000 +0100
+@@ -1,7 +1,6 @@
+ # This makefile is on purpose not made with configure, to show how to use the library
+ # The make file requires that the fann library is installed (see ../README)
+
+-GCC=gcc
+
+ TARGETS = xor_train xor_test xor_test_fixed simple_train steepness_train simple_test robot mushroom cascade_train scaling_test scaling_train
+ DEBUG_TARGETS = xor_train_debug xor_test_debug xor_test_fixed_debug cascade_train_debug
+@@ -9,10 +8,10 @@
+ all: $(TARGETS)
+
+ %: %.c Makefile
+- $(GCC) -O3 $< -o $@ -lfann -lm
++ $(CC) $(CFLAGS) $< -lfann -lm -o $@
+
+ %_fixed: %.c Makefile
+- $(GCC) -O3 -DFIXEDFANN $< -o $@ -lfixedfann -lm
++ $(CC) $(CFLAGS) -DFIXEDFANN $< -lfixedfann -lm -o $@
+
+ clean:
+ rm -f $(TARGETS) $(DEBUG_TARGETS) xor_fixed.data *.net *~ *.obj *.exe *.tds noscale.txt withscale.txt scale_test_results.txt
diff --git a/sci-mathematics/fann/metadata.xml b/sci-mathematics/fann/metadata.xml
new file mode 100644
index 000000000000..0e980124731f
--- /dev/null
+++ b/sci-mathematics/fann/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fast Artificial Neural Network Library implements multilayer artificial
+ neural networks in C with support for both fully connected and sparsely
+ connected networks. Cross-platform execution in both fixed and floating
+ point are supported. It includes a framework for easy handling of
+ training data sets. It is easy to use, versatile, well documented, and
+ fast. Delphi, PHP, Python and other bindings are available.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">fann</remote-id>
+ </upstream>
+</pkgmetadata>