summaryrefslogtreecommitdiff
path: root/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/factmsieve/factmsieve-76-r1.ebuild')
-rw-r--r--sci-mathematics/factmsieve/factmsieve-76-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild b/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild
new file mode 100644
index 000000000000..b8e607498d38
--- /dev/null
+++ b/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Convenient factorization helper script using msieve and ggnfs"
+HOMEPAGE="http://gladman.plushost.co.uk/oldsite/computing/factoring.php"
+SRC_URI="http://gladman.plushost.co.uk/oldsite/computing/${PN}.${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sci-mathematics/msieve
+ sci-mathematics/ggnfs"
+DEPEND=""
+
+S="${WORKDIR}"
+PATCHES=( "${FILESDIR}/${P}.patch" )
+
+src_install() {
+ python_fix_shebang ${PN}.py
+ dobin ${PN}.py
+}