summaryrefslogtreecommitdiff
path: root/sci-mathematics/euler/euler-1.61.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/euler/euler-1.61.0-r1.ebuild')
-rw-r--r--sci-mathematics/euler/euler-1.61.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-mathematics/euler/euler-1.61.0-r1.ebuild b/sci-mathematics/euler/euler-1.61.0-r1.ebuild
new file mode 100644
index 000000000000..b54a13030b48
--- /dev/null
+++ b/sci-mathematics/euler/euler-1.61.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Mathematical programming environment"
+HOMEPAGE="http://euler.sourceforge.net/"
+SRC_URI="mirror://sourceforge/euler/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc -sparc x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="x11-libs/gtk+:2"
+RDEPEND="
+ ${DEPEND}
+ x11-misc/xdg-utils
+"
+
+PATCHES=(
+ "${FILESDIR}"/configure-gentoo.patch
+ "${FILESDIR}"/command-gcc4-gentoo.patch
+ "${FILESDIR}"/${PN}-glibc-2.4-gentoo.patch
+ "${FILESDIR}"/${PN}-xdg.patch
+ "${FILESDIR}"/${PN}-fortify.patch
+)
+
+src_prepare() {
+ default
+
+ # gentoo specific stuff
+ sed -i -e '/COPYING/d' -e '/INSTALL/d' Makefile.am || die
+ sed -i \
+ -e "s:doc/euler:doc/${PF}:g" \
+ Makefile.am docs/Makefile.am \
+ docs/*/Makefile.am docs/*/images/Makefile.am src/main.c \
+ || die "sed for docs failed"
+
+ eautoreconf
+}