summaryrefslogtreecommitdiff
path: root/sci-mathematics/dunshire
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/dunshire')
-rw-r--r--sci-mathematics/dunshire/Manifest4
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.1-r4.ebuild38
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.3.ebuild26
3 files changed, 28 insertions, 40 deletions
diff --git a/sci-mathematics/dunshire/Manifest b/sci-mathematics/dunshire/Manifest
index 3f2243e112de..d3f7ef8147d7 100644
--- a/sci-mathematics/dunshire/Manifest
+++ b/sci-mathematics/dunshire/Manifest
@@ -1,3 +1,3 @@
-DIST dunshire-0.1.1.tar.gz 300878 BLAKE2B b0ed57e535313fbc653fdc7c8fd32fb98382db71dfe419e315f4b82fc4630e47757d74b9105e846b2eefaa7dcd93b12886eee341b11d0e8b562a52e480478e9a SHA512 5cdf8125d7fc1f76a483009392360e9e9088f9b58ca3f123d14e366421e831e4e7c8e17d367ba0430fb3cd61873cae7a004c903ff5417bfc9adecb7831681081
-EBUILD dunshire-0.1.1-r4.ebuild 946 BLAKE2B 6218c8b92c78e05909ec6283d291451eaa651f9c1549f4347d0af339d9feaf99d6975911483e18f9ff3637ce89fe0f9fdd55d589b5026038d940d6812f2123d4 SHA512 6866eb11372931823e626cc9d06e84898edf0622a4e2b450c66823df28f586e8e4c0a86ba613e313f63257006f9800cbd73d0ebff5ecd684c059620c3a8783e0
+DIST dunshire-0.1.3.tar.gz 52450 BLAKE2B 047f732daa7f2a53b8d24ea0aafdad3234aa5ee151a66f776ba22746d58b4b91a5047ba615978d4017e56345ac608fd1f537adef06f38b5a429276e284a88d02 SHA512 227d142347ad7b7eb5b283aaa94f457b20b686f40aa86b2a74057eed00d3d90e87fb4a0f32071db3bd73412489794a0b398a557f8194931a6e7d51ff442aa2b0
+EBUILD dunshire-0.1.3.ebuild 629 BLAKE2B b8a5e9713be85e33598b6a46ebf0cf7218a6e78cc039c0ac385afa87147ee1663f3f66e7aba39f43e6f72f091e87b80591dcc370edabbebfe7166f0c856e42c4 SHA512 ac743d92df8d03b7a25b4585e6fdb7fcc97ead47895947c4c6e2ea6115d6ae7f2a43a92b230eb085f394ddc1bc08ce427609561d84d6850b56046800410fb449
MISC metadata.xml 329 BLAKE2B e9cf64a4fd7f360e350a97ca0a9efe8e64ce485f2b025e456271c8e3d8bbf3f6950750a157eaa66e0639a800285351f84abd07789697acfbaf5422b9cb725ec6 SHA512 f8f757c9f662dfba3c0717720a7d2fe6e2c2bea517d6811cf9785d39cef92714c0ddddf3c56eecb6be37fc97fcd6ebdeba0412108b41ffc0c9cdde34c3e8a74a
diff --git a/sci-mathematics/dunshire/dunshire-0.1.1-r4.ebuild b/sci-mathematics/dunshire/dunshire-0.1.1-r4.ebuild
deleted file mode 100644
index 517eaddf4641..000000000000
--- a/sci-mathematics/dunshire/dunshire-0.1.1-r4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python library to solve linear games over symmetric cones"
-HOMEPAGE="https://michael.orlitzky.com/code/dunshire/"
-
-LICENSE="AGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
-
-# Tests run on the build host? Bug #693916. There's one doctest that
-# uses a numpy matrix, sorry. That will be fixed in the next release.
-# Otherwise numpy is not needed; the required interfaces are provided
-# through cvxopt.
-BDEPEND="test? (
- ${RDEPEND}
- dev-python/numpy[${PYTHON_USEDEP}]
-)"
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- local DOCS=( doc/README.rst )
- distutils-r1_python_install_all
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/sci-mathematics/dunshire/dunshire-0.1.3.ebuild b/sci-mathematics/dunshire/dunshire-0.1.3.ebuild
new file mode 100644
index 000000000000..ac63ace2d98f
--- /dev/null
+++ b/sci-mathematics/dunshire/dunshire-0.1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python library to solve linear games over symmetric cones"
+HOMEPAGE="https://michael.orlitzky.com/code/dunshire/"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
+DOCS=( doc/README.rst )
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests setup.py
+
+python_test() {
+ esetup.py test
+}