summaryrefslogtreecommitdiff
path: root/sci-mathematics/cudd/cudd-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/cudd/cudd-3.0.0.ebuild')
-rw-r--r--sci-mathematics/cudd/cudd-3.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-mathematics/cudd/cudd-3.0.0.ebuild b/sci-mathematics/cudd/cudd-3.0.0.ebuild
new file mode 100644
index 000000000000..23d19b084202
--- /dev/null
+++ b/sci-mathematics/cudd/cudd-3.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Colorado University binary Decision Diagram library"
+HOMEPAGE="https://davidkebo.com/cudd/"
+SRC_URI="https://davidkebo.com/source/cudd_versions/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ local myconf=(
+ --enable-dddmp
+ --enable-obj
+ --enable-shared
+ )
+ econf ${myconf[@]}
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -type f -delete || die
+}