summaryrefslogtreecommitdiff
path: root/sci-mathematics/coq/coq-8.17.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/coq/coq-8.17.1.ebuild')
-rw-r--r--sci-mathematics/coq/coq-8.17.1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/sci-mathematics/coq/coq-8.17.1.ebuild b/sci-mathematics/coq/coq-8.17.1.ebuild
index f634026e1cda..fb5c53f57eed 100644
--- a/sci-mathematics/coq/coq-8.17.1.ebuild
+++ b/sci-mathematics/coq/coq-8.17.1.ebuild
@@ -110,3 +110,12 @@ src_install() {
einstalldocs
}
+
+pkg_preinst() {
+ # bug https://bugs.gentoo.org/910236
+ if has_version "sci-mathematics/coq:0/8.12.0" && [[ ! -L /usr/lib64/coq ]]
+ then
+ einfo "Removing colliding directory from version 8.12: /usr/lib64/coq"
+ rm -rf /usr/lib64/coq
+ fi
+}