summaryrefslogtreecommitdiff
path: root/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch')
-rw-r--r--sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch b/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch
new file mode 100644
index 000000000000..061ddac84194
--- /dev/null
+++ b/sci-mathematics/btor2tools/files/btor2tools-1.0.0_pre20220518-cmake-also-static.patch
@@ -0,0 +1,28 @@
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1,4 +1,5 @@
+ add_library(btor2parser
++ SHARED
+ btor2parser/btor2parser.c
+ )
+ target_include_directories(btor2parser PRIVATE .)
+@@ -10,6 +11,19 @@ install(
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ )
+
++add_library(btor2parser_static
++ STATIC
++ btor2parser/btor2parser.c
++)
++target_include_directories(btor2parser_static PRIVATE .)
++set_target_properties(btor2parser_static PROPERTIES OUTPUT_NAME btor2parser)
++set_target_properties(btor2parser_static PROPERTIES PUBLIC_HEADER btor2parser/btor2parser.h)
++install(
++ TARGETS btor2parser_static
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
++)
++
+ add_executable(btorsim
+ btorsim/btorsimam.cpp
+ btorsim/btorsimstate.cpp