summaryrefslogtreecommitdiff
path: root/sci-mathematics/4ti2
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/4ti2')
-rw-r--r--sci-mathematics/4ti2/4ti2-1.6.2.ebuild37
-rw-r--r--sci-mathematics/4ti2/4ti2-1.6.5.ebuild37
-rw-r--r--sci-mathematics/4ti2/4ti2-1.6.6.ebuild37
-rw-r--r--sci-mathematics/4ti2/4ti2-1.6.7.ebuild43
-rw-r--r--sci-mathematics/4ti2/Manifest12
-rw-r--r--sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch17
-rw-r--r--sci-mathematics/4ti2/metadata.xml12
7 files changed, 195 insertions, 0 deletions
diff --git a/sci-mathematics/4ti2/4ti2-1.6.2.ebuild b/sci-mathematics/4ti2/4ti2-1.6.2.ebuild
new file mode 100644
index 000000000000..d107c3deb4a7
--- /dev/null
+++ b/sci-mathematics/4ti2/4ti2-1.6.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+# The swig subdir is not used, so we can skip running autotools in it. #518000
+AT_NO_RECURSIVE=1
+
+inherit autotools-utils
+
+DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
+HOMEPAGE="http://www.4ti2.de/"
+SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-macos"
+IUSE="static-libs"
+
+DEPEND="
+ sci-mathematics/glpk:0[gmp]
+ dev-libs/gmp[cxx]"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2-gold.patch
+ )
+
+src_prepare() {
+ sed \
+ -e "s:^CXX.*$:CXX=$(tc-getCXX):g" \
+ -i m4/glpk-check.m4 || die
+ autotools-utils_src_prepare
+}
diff --git a/sci-mathematics/4ti2/4ti2-1.6.5.ebuild b/sci-mathematics/4ti2/4ti2-1.6.5.ebuild
new file mode 100644
index 000000000000..816cc21252a4
--- /dev/null
+++ b/sci-mathematics/4ti2/4ti2-1.6.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+# The swig subdir is not used, so we can skip running autotools in it. #518000
+AT_NO_RECURSIVE=1
+
+inherit autotools-utils
+
+DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
+HOMEPAGE="http://www.4ti2.de/"
+SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE="static-libs"
+
+DEPEND="
+ sci-mathematics/glpk:0[gmp]
+ dev-libs/gmp[cxx]"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2-gold.patch
+ )
+
+src_prepare() {
+ sed \
+ -e "s:^CXX.*$:CXX=$(tc-getCXX):g" \
+ -i m4/glpk-check.m4 || die
+ autotools-utils_src_prepare
+}
diff --git a/sci-mathematics/4ti2/4ti2-1.6.6.ebuild b/sci-mathematics/4ti2/4ti2-1.6.6.ebuild
new file mode 100644
index 000000000000..63371b8f47d1
--- /dev/null
+++ b/sci-mathematics/4ti2/4ti2-1.6.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+# The swig subdir is not used, so we can skip running autotools in it. #518000
+AT_NO_RECURSIVE=1
+
+inherit autotools-utils
+
+DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
+HOMEPAGE="http://www.4ti2.de/"
+SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~x86-macos"
+IUSE="static-libs"
+
+DEPEND="
+ sci-mathematics/glpk:0[gmp]
+ dev-libs/gmp[cxx]"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2-gold.patch
+ )
+
+src_prepare() {
+ sed \
+ -e "s:^CXX.*$:CXX=$(tc-getCXX):g" \
+ -i m4/glpk-check.m4 || die
+ autotools-utils_src_prepare
+}
diff --git a/sci-mathematics/4ti2/4ti2-1.6.7.ebuild b/sci-mathematics/4ti2/4ti2-1.6.7.ebuild
new file mode 100644
index 000000000000..c06748c20172
--- /dev/null
+++ b/sci-mathematics/4ti2/4ti2-1.6.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
+HOMEPAGE="http://www.4ti2.de/"
+SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+DEPEND="
+ sci-mathematics/glpk:0[gmp]
+ dev-libs/gmp[cxx]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2-gold.patch
+)
+
+src_prepare() {
+ default
+ sed -e "s:^CXX.*$:CXX=$(tc-getCXX):g" \
+ -i m4/glpk-check.m4 || die
+ # The swig subdir is not used, so we can skip running autotools in it. #518000
+ AT_NO_RECURSIVE=1 eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+}
diff --git a/sci-mathematics/4ti2/Manifest b/sci-mathematics/4ti2/Manifest
new file mode 100644
index 000000000000..fcde6e20ca80
--- /dev/null
+++ b/sci-mathematics/4ti2/Manifest
@@ -0,0 +1,12 @@
+AUX 4ti2-1.3.2-gold.patch 652 SHA256 50ebe74bb3fc8c0863a12823e52f4dc9d1fe7ab6e8674d53453adb5fd8460601 SHA512 60b14d7b287b69adbce420f37dad5d83ce21bfa4329ea0810c67f054d35a71f6795b0a8206b268ec9cfa08f796a4cd80a34d816c691e8e3e77adcbc5217b43a7 WHIRLPOOL ac0358e169846be7ac75380d69752f24b8bd5e9a68e4ad59abc840fcf86c6998f76df37888cf305ab2c4bf8b96dd2ce566f13a434f0522f377f8feb337b1e22b
+DIST 4ti2-1.6.2.tar.gz 5531651 SHA256 e1b39c5c051904e41deefce5419b16d723b1f403c616ddd6e3610e260d4b5711 SHA512 ff68f767b8677ce0ce94cca39fa3ef87835d77a951f0ec6ae28ab171bf09ae25c551d88c2cdf5bf3115b33bd32366b063533a1c22576130a00f542f9370bcd7b WHIRLPOOL f125cee526f8d2693b01978fd39cc36c900e7611ac0b8026f33c68ec8ccb0bb29cdffdf5c11adc6a5f7041389d34e6cacff173437c4be725c9b390a25e24e397
+DIST 4ti2-1.6.5.tar.gz 5640117 SHA256 079abe725fb1cc811184eca1d079a51f701a20c02c894422be59cd923c2cd21b SHA512 90dc105d99659e3c2213b484b6d21e877d7484ca0ad0373ece066df26de7c0e0cce614faaae9f7b678d03fa54f987fe95ab6d3f958477b1294a2dc00733a3a08 WHIRLPOOL b72d84e4e9557f85cadd3d93305b19162e85321bbc8dc974febe5f01e4a218c61d5e831de0ae8fc294e0f21c2469c663e53dde41f2e943db9df6011b758c1ccf
+DIST 4ti2-1.6.6.tar.gz 5640126 SHA256 2ae9f7dd6a387fd6f0454b4bc2d02cf389f504230cc9f782c35bb5ea4a8df10a SHA512 89f36aaf3d8f41bb31b37b44a013ea966d9664880473ad0d6d1825ffb00afec1eff3139c09ac6b684f0679e2ae0d201a84396bb721aa1f63dc1deca592392c41 WHIRLPOOL c5255ffe43eb65ec7d19f8cf24de3ab69e5f2466a91009a336a367cfab768d882781a91ab82d3077600edc08c6fb3f6f3686536e8e5bcbc6a1ca16f1feaa0ef0
+DIST 4ti2-1.6.7.tar.gz 5649869 SHA256 d4833a831d8d437f595d2e234a4471d7adbe1523fc63aa46cacea56af3e831bb SHA512 38d638fe01ff3cef1aebae1eefd276cf02f808978851b4465e132f77d3ab34ea51d512e2ea28a42ac65263b458c43cf420dc5f8ac930f959dd0c14916cef9841 WHIRLPOOL c2159243d6664e1c7a0b880e336055d7f53b8367f36c7b5255cad0f3b861d8c1e9ab109cb5d5b243a934df8ca1f95e61f85496fa54354d131447b0fb70c13048
+EBUILD 4ti2-1.6.2.ebuild 789 SHA256 3d23abace99194ea30f381da9ed0d8ec6f96e2b8645a7b83ca6ad7ee6a8f93fc SHA512 58e22453125f1329e5df372b4ed2bf3672de5180acd3667e90b528211a427c18ce77e041e91ab13ff96157f329210ed40771779940b323e5ef330aba417aabe4 WHIRLPOOL a9ee9210c34afcf66fb0dc0ad94c63b4408579db2d7d6237521f1cfec034153895968c6f93489d8b45e582358fe2acfb55bc90c785843533b4a243f49dc01945
+EBUILD 4ti2-1.6.5.ebuild 791 SHA256 fe2b9ac6ce0ff70a6d8f1f2ba36b3485f77b1fd351c2fead62dd68dddd9a7d4d SHA512 4951d3a3e5ddaf1641e0466e5601350b69c46f6e184a20d23466140bdc958e5538663dce8bb1e2395316dd63499a93d0eaef224188f407c7cb45104cc073652d WHIRLPOOL e56c202616789a74765511b5e62a77bca7283e9ef5faa74e5e0324a9af0b89005c7e145a1f81a54999490fe7ed2f7c91e8a647b8dbafbae2708aa0d9d52e67a2
+EBUILD 4ti2-1.6.6.ebuild 798 SHA256 a829827c2cf467b3af47565129bc68e04748bd0c4d760dcb880ba3cb76b846a9 SHA512 e531966d6b40f7da358890db343d62536cd1947c5473a4e310e1bc639701442a779e6b37697bbaa9c1d3a25f5a5c4621ca6e5129361e9314bedeeade2e5a885e WHIRLPOOL ec61890451ab63e4b3048407d892193728285f19b523c3423a7a034cf0362315c2e72ac07755e61df6f49c6aa57d2042582d9b73166c2731681307e1809cdce2
+EBUILD 4ti2-1.6.7.ebuild 918 SHA256 a72d8875394fce3584c7907bef729019afb1e458cf63f8af7ac71ecb35a37d07 SHA512 b492edd19531900aa43ba8f945d3bbb804e15156e1a096b1045358a1fbbd0537bfe2ebe568dc8ca2e12045303ff7b16d57c0349865ac503842fd62b602b274ff WHIRLPOOL 8acfe0643ce2febf7d5ad5dc0b06d59267c38939cff81b6898e37fe2d92488cfc074ef153e7ca6acc5d3a8fd5c7e4e464847a34adf0adb4f90bc9c92dd61885a
+MISC ChangeLog 3072 SHA256 29c13f08174277b22f3d9f9dfcaf90bf4310f88d5ab5ea4a9ba361594b3de67a SHA512 a6da631da8c77aee8c7586a07cbc2ba65bc070bb033b2bbd679eac360dbd0a1c34a16486c5b1058002418e1ccc00c6b1071c0203449826c8e54104f1389ac465 WHIRLPOOL 2cc66d4de3dc699483c84b37c2c2b60d168df9d449c793a51843a90230cd12bac8685daf0e82b0f7d6fa4c9460358374024f5be0387d7c681c8788aa8aac64a1
+MISC ChangeLog-2015 3437 SHA256 256bdcae54b58b0d08006988f9ee8f721e2c23e8fbe88d849ddfe2c1d9233fad SHA512 806e26e49a52611b3bc33bfbe4d0fee1623ca44a2e39188c73892f14e896172cc152a3cbd525bbf1124e69bcc0d535fadb07af78946a06b334f280aa0a7d4778 WHIRLPOOL e09411d7de7ccd1f1a12fe8d4f2b52f16c6029515d2fe5c05d7209ea53b3b56c75f218dc2af18787ba527d9b21b38f235894857bd763cecee69ef51ab8fe735b
+MISC metadata.xml 446 SHA256 3719f31df109749d5b09e66b108d498d5802ce8d0d294ff41f5ec30a87d20957 SHA512 2c7950b353c54597eebcff1f50e5045f792ef37cfe59f0142160bdf5ea47ff6be57bd698b051e6c56863b109fde983c1aeeca87827289abde96838af1aa3f7d1 WHIRLPOOL 027b45b9401cb32e220777ac286a387011ef19431660c46143d0709458ce2457b302d2edf7e842428090405480b159b0803cd8131a677616ce2bb290f3a4392e
diff --git a/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch b/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch
new file mode 100644
index 000000000000..bb1e8c4aad39
--- /dev/null
+++ b/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch
@@ -0,0 +1,17 @@
+ m4/glpk-check.m4 | 2 +-
+ src/groebner/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/groebner/Makefile.am b/src/groebner/Makefile.am
+index 992c4ae..ba2f463 100644
+--- a/src/groebner/Makefile.am
++++ b/src/groebner/Makefile.am
+@@ -269,7 +269,7 @@ lib4ti2int64_la_SOURCES = $(lib4ti2sources)
+ # Arbitrary precision flags.
+ # 4ti2 uses GMP (GLPL), an arbitrary precision arithmetic library.
+ if HAVE_GMP_WITH_CXX
+-4ti2gmp_LDADD = lib4ti2gmp.la
++4ti2gmp_LDADD = lib4ti2gmp.la -lgmp
+ 4ti2gmp_CPPFLAGS = -D_4ti2_GMP_ $(GMP_CFLAGS)
+ 4ti2gmp_SOURCES = $(4ti2sources)
+ lib4ti2gmp_la_CPPFLAGS = -D_4ti2_GMP_
diff --git a/sci-mathematics/4ti2/metadata.xml b/sci-mathematics/4ti2/metadata.xml
new file mode 100644
index 000000000000..69d5057d7b72
--- /dev/null
+++ b/sci-mathematics/4ti2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+4ti2 is a software package for algebraic, geometric and combinatorial problems
+on linear spaces and for toric ideals too.
+</longdescription>
+</pkgmetadata>