summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin45275 -> 45277 bytes
-rw-r--r--sci-libs/ceres-solver/Manifest2
-rw-r--r--sci-libs/ceres-solver/ceres-solver-2.2.0.ebuild89
-rw-r--r--sci-libs/metis/Manifest2
-rw-r--r--sci-libs/metis/metis-5.2.1-r2.ebuild4
-rw-r--r--sci-libs/scikit-learn/Manifest4
-rw-r--r--sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild64
-rw-r--r--sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild29
8 files changed, 118 insertions, 76 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index ab6e87feef0e..f6741c7ece1e 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/ceres-solver/Manifest b/sci-libs/ceres-solver/Manifest
index 1b9277657400..1d88e9e21552 100644
--- a/sci-libs/ceres-solver/Manifest
+++ b/sci-libs/ceres-solver/Manifest
@@ -1,4 +1,6 @@
AUX ceres-solver-2.0.0-system-mathjax.patch 325 BLAKE2B a649088517ec1bef7d5a6144de57657daeff2b5a1a0b053c0bfa81d8af7143ad5d829571be947d8853bd6d1fe39adc63b4f14a4075004775151fa649747911c6 SHA512 e16646210fddb350f5cc43665afaa88d2ffe53c817dab778c0e2534c1a0001242865a547e8a308621a9068555e7e20a57e83b0447ff5d32688ed5fb3f5694d29
DIST ceres-solver-2.1.0.tar.gz 3802187 BLAKE2B d8ff780cf9b9de2541c15a2b95bde07a2d1c8e60bab3a8a4b13134b99da699da452467afe3310b9f70c3c2a6bd033ea3c4bd3c401153899e9c70867fae30c633 SHA512 db777c4a4b85a9972628c714413fe9ca1a92cc6c8b14d80401842a02c4d7e7df4e9d236775e231e8337e47f21e47cd82c1a0fbcfeffbd9b654e46a66262996f2
+DIST ceres-solver-2.2.0.tar.gz 7635532 BLAKE2B ecdd5147e235df711705fc262fad18cfc79f8cfaaa9aba41428c70ae5996aab44c44e5b7d3f62d8ab4633ec2d7511c39191323911fea1276f5797e900c42bc60 SHA512 bf519fbcbd0ee2d4624be72cde061a09d191ee5e56dc33984669393799b885c2164efc99dcef71307f8b50a9ccad945882376ace3d9a44ba7e1f25c20511aabd
EBUILD ceres-solver-2.1.0-r1.ebuild 2426 BLAKE2B 05047be09beed316cc5d288923a31553f9ee3c4afb01b83265b67be04d84dd9104b3c444f867a1a9b632ef6fb013e4556897f7bc0da7dbdc9ccefe647a994689 SHA512 c46f722f17201355c791fea3e3229c2fd8fa74432205635abd68d20544039f879196ebec6ffda10b40a9138a4c9e507724de2e7bd48d2a7e07cf12629bb88869
+EBUILD ceres-solver-2.2.0.ebuild 1975 BLAKE2B 91449c74c31e3116073c8f5081fd71d8ef05652e01a29586451ee58ada90f2767524f3b2e9d90cbbdb84c14ecba3235f670da7cc543af98c20cd8fafbda34d18 SHA512 64e2136f0199f60d2195a246c68c42fa88c9aab693bc6471b622f6d16e46f998d58ee138f2a58a44544d219f6737e5c1e1c9710a31fd9f9b8e7809c1cf2f05a3
MISC metadata.xml 1454 BLAKE2B af5a9cef52650cff056c7804782e7024696ed9122e8998faad23796960d94155f5f318cec2750a4ead6610f89fe55e49301a30ec62bfc846ea2a955a430f42cf SHA512 cf928d9400bbac7ba003ad44fc6c1d77cef43a58d2cc9b399ee854880ad75b38062e3a61899403eda529e7eaba528606a8da25b5e287c53bc4721d025b6a7e59
diff --git a/sci-libs/ceres-solver/ceres-solver-2.2.0.ebuild b/sci-libs/ceres-solver/ceres-solver-2.2.0.ebuild
new file mode 100644
index 000000000000..6abc595b8231
--- /dev/null
+++ b/sci-libs/ceres-solver/ceres-solver-2.2.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DOCS_BUILDER="sphinx"
+DOCS_DEPEND="dev-python/sphinx-rtd-theme"
+DOCS_DIR="docs/source"
+inherit cmake-multilib flag-o-matic python-any-r1 docs
+
+DESCRIPTION="Nonlinear least-squares minimizer"
+HOMEPAGE="http://ceres-solver.org/"
+SRC_URI="http://ceres-solver.org/${P}.tar.gz"
+
+LICENSE="sparse? ( BSD ) !sparse? ( LGPL-2.1 )"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples gflags lapack +schur sparse test"
+
+REQUIRED_USE="test? ( gflags ) sparse? ( lapack ) abi_x86_32? ( !sparse !lapack )"
+RESTRICT="!test? ( test )"
+
+BDEPEND="${PYTHON_DEPS}
+ >=dev-cpp/eigen-3.3.4:3
+ lapack? ( virtual/pkgconfig )
+ doc? ( <dev-libs/mathjax-3 )
+"
+RDEPEND="
+ dev-cpp/glog[gflags?,${MULTILIB_USEDEP}]
+ lapack? ( virtual/lapack )
+ sparse? (
+ sci-libs/amd
+ sci-libs/camd
+ sci-libs/ccolamd
+ sci-libs/cholmod[metis(+)]
+ sci-libs/colamd
+ sci-libs/spqr
+ )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md VERSION )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.0-system-mathjax.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ filter-lto
+
+ # search paths work for prefix
+ sed -e "s:/usr:${EPREFIX}/usr:g" \
+ -i cmake/*.cmake || die
+
+ # remove Werror
+ sed -e 's/-Werror=(all|extra)//g' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ # CUSTOM_BLAS=OFF EIGENSPARSE=OFF MINIGLOG=OFF CXX11=OFF
+ local mycmakeargs=(
+ -DBUILD_BENCHMARKS=OFF
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DBUILD_TESTING=$(usex test)
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DGFLAGS=$(usex gflags)
+ -DLAPACK=$(usex lapack)
+ -DSCHUR_SPECIALIZATIONS=$(usex schur)
+ -DSUITESPARSE=$(usex sparse)
+ -DEigen3_DIR=/usr/$(get_libdir)/cmake/eigen3
+ )
+
+ use sparse || mycmakeargs+=( -DEIGENSPARSE=ON )
+
+ cmake-multilib_src_configure
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples data
+ fi
+}
diff --git a/sci-libs/metis/Manifest b/sci-libs/metis/Manifest
index 49c9bfb50ec2..0f14ec5b2c19 100644
--- a/sci-libs/metis/Manifest
+++ b/sci-libs/metis/Manifest
@@ -7,5 +7,5 @@ AUX metis-5.2.1-respect-user-flags.patch 1258 BLAKE2B aadf0612d276228bc0fc116534
DIST metis-5.1.0.tar.gz 4984968 BLAKE2B c5f8ff552fce7e7cc02740e6197c9deb5e05e8bc2e2e56cad0cba85705eec6990b511182930c8758fd16a18015f54c8a4827038039bc3c58ee41df468ea175bc SHA512 deea47749d13bd06fbeaf98a53c6c0b61603ddc17a43dae81d72c8015576f6495fd83c11b0ef68d024879ed5415c14ebdbd87ce49c181bdac680573bea8bdb25
DIST metis-5.2.1.tar.gz 4838377 BLAKE2B 7f2bb3b4dce71cd05e25d042095c311f814d5d197b1a6ae19994b6bcbb7d948d3a96210cbce5633f39d7bb8ad7cc3f8f4977c6465ec8591934aac00ea9637c94 SHA512 69127b7a777f9ba14cf399a7122000af9d6094a5f44be600a28384cfc0495c024fb0c6eab37c4473a5763ec1077cd9f30d9bcbb3c952462f6c9ead31c6b9e790
EBUILD metis-5.1.0-r5.ebuild 1829 BLAKE2B 34c689ef43ee52bb0c13d654daf6f44d436c4edf845f6b02d57f21e200dbee5444a4ba788c41a9b937703b9f8532f70d4b56fc9ed9c0cede37825695c51f0a5e SHA512 aad2f154fc7ef7ebe6f0061b7c74c422ec588a6a7df5cdd5ce207930c211a27bfc533e2083130642110a3164b41097bd8a0aa32d8a130b6e5b6f3f28a756cc9f
-EBUILD metis-5.2.1-r2.ebuild 2220 BLAKE2B b035b7286e8247dad1b83386b89338ed052613cc0eb97444bff02c73a52b1e26b89b3faf448c9b1e3ce5149eb332e819b461d5258b5b5555461f3a7f403f7507 SHA512 62daceb87e24bc88074147a705d5ce2b9e1290f7beee4607d9739abedb534c344be9858fe2023483df7786c28069edde2302308c9d201b1a49db943744aecfd0
+EBUILD metis-5.2.1-r2.ebuild 2215 BLAKE2B 085f884a768fbc18516a051c722e6c341bd089bbfd2375fcf8601df5fac0f89dd11adfac204b0153c9a5eb9d4a2bf175e567d4d6cc0a95f2106c7fca96c4630c SHA512 1d7a64240c92574024277ba2d93cb8ca8874f48ecd23a6c9ee0e00beb76888209e7fbb77e5d41ea7bf6e200c14569f839c4348ab669342a9ceff51ad1ddd52e0
MISC metadata.xml 947 BLAKE2B 9687c616dd1c8684be3fc1022671560ac5ff752514cbced0a3bb1bfc70348ecdb72c4913e65720a70f03609a1277c5a697e5985fb0cb8032d60e5c24f9b16674 SHA512 efa12e77a7af2803d0626eefc85aaaa5b2594fdfc748c8ad870590f65ae40ec7e557fa923707f327b8bb04036b57a67a036fed52ff9159af1fe65c062165408f
diff --git a/sci-libs/metis/metis-5.2.1-r2.ebuild b/sci-libs/metis/metis-5.2.1-r2.ebuild
index 91a2647cce3d..3f6300981bd1 100644
--- a/sci-libs/metis/metis-5.2.1-r2.ebuild
+++ b/sci-libs/metis/metis-5.2.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ S="${WORKDIR}/METIS-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ~ppc ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~arm64-macos ~x64-macos"
IUSE="double-precision examples int64 openmp"
PATCHES=(
diff --git a/sci-libs/scikit-learn/Manifest b/sci-libs/scikit-learn/Manifest
index 843a753b4fed..93c832da8178 100644
--- a/sci-libs/scikit-learn/Manifest
+++ b/sci-libs/scikit-learn/Manifest
@@ -1,5 +1,3 @@
-DIST scikit-learn-1.1.2.gh.tar.gz 7104556 BLAKE2B e67e1deddf5a1134b57a146e8271a406cb257ffc92c9719e90f5b9d98e711b68bc67e3367660ecaad61aaec1794bb8999b4dd00b7d56e21eca8fcb2ee72cc9aa SHA512 58789c1e607d7de3339fa3b8928553ca96cef93e8da8fd13612aa78e5ebde8e6a55e3bf7845f9a45b78ed77da6a219d08d2c26318b602f937e0e3debd239293e
DIST scikit-learn-1.3.2.gh.tar.gz 7650823 BLAKE2B 170699917f46d6d3f4b9ebc314bc1ec45687dad0a4aec5d2cee6e288b5dbe508bad6dd80406501f289a33593c6482067393e9dc28155f85a4872a34523bf4199 SHA512 a3799e9b39b755a50ba225f836904a378f7d83a08274c614d0485e4d4d4a7b0c7adba2dbb6612f2ccb4e5167f872214a2853eff69d767dc70f52369bda7a230b
-EBUILD scikit-learn-1.1.2.ebuild 1630 BLAKE2B 75231c2493783f4cfb3c5979cd813357fda3bf8f2f435963d8c788665eba387a8351a5630a85d43699b63a63edf7cde653cafbba23f1373cb57b0f9d909886cb SHA512 95e49f1dfb0c032302bd5e9b6ce7773c3a099a3311d2aaf398eff68c93531278a010c1768bb25ca17e76067485fb18915766ecfa8ad71fc173b73d7e1769da02
-EBUILD scikit-learn-1.3.2-r1.ebuild 1606 BLAKE2B b9cacd1e25aeeccdee743009ea49001cceedf40fd0cbfdfc0a1978457b70c77e8a47e5679b7913e10bb990a553bb29a4ea9eee187f88afcb2afaecc84a8a456f SHA512 c1d7c3db9a10c87fe3c2e8e265f27ebc3dd9945cfd55ee423c2870fb217a96e4a0cef8c288b98362e793005d34fc84e11065ad74e29fb9b4f50251208d631bb1
+EBUILD scikit-learn-1.3.2-r1.ebuild 1937 BLAKE2B 633a70b5f27f2ad9a3e1ccbc0f560aa3e4e41768827d2fe7f89009712c105829a545de79b2acdb7e45d7ff4f83d555ba138f4bbff76038474996e2fa8eec3b78 SHA512 b09e1c642450e0bc10b213a3171962dd262f550926424c10de11711597c70c0915a140a30ffe6f255c5751bce9938b7874a0b9feebc51d71d042830f1991e7b6
MISC metadata.xml 614 BLAKE2B b5425c2d022592581647c9b97c0ab22bfc2afe347b2e5ea22f141245238f145322f39406c62318ba1e6af1462b2691267b39976bfde38faaf1d28b1d29c4e015 SHA512 74ac79123848bc385c29fcfdc4a1e780529dda685c1deb5eb722f5d4919ee6ac9d80798d52c4af0be0cc8dbbaea3784963dd97e2b7c1258cc2f5605b0bc8907a
diff --git a/sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild b/sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild
deleted file mode 100644
index 19c4f027d4bc..000000000000
--- a/sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="https://scikit-learn.org/stable/"
-SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
-IUSE="examples"
-
-# Fatal Python error: Segmentation fault
-RESTRICT="test"
-
-DEPEND="
- virtual/blas:=
- virtual/cblas:=
-"
-RDEPEND="
- ${DEPEND}
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/joblib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/threadpoolctl[${PYTHON_USEDEP}]
-"
-# <cython-3: https://bugs.gentoo.org/911369
-BDEPEND="
- <dev-python/cython-3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-# For some reason this wants to use urllib to fetch things from the internet
-# distutils_enable_sphinx doc \
-# dev-python/matplotlib \
-# dev-python/memory-profiler \
-# dev-python/numpydoc \
-# dev-python/pandas \
-# dev-python/pillow \
-# dev-python/seaborn \
-# dev-python/sphinx-gallery \
-# dev-python/sphinx-prompt \
-# dev-python/scikit-image
-
-python_test() {
- # This needs to be run in the install dir
- cd "${WORKDIR}/${P}-${EPYTHON//./_}/install/usr/lib/${EPYTHON}/site-packages/sklearn" || die
- distutils-r1_python_test
-}
-
-python_install_all() {
- find "${S}" -name \*LICENSE.txt -delete || die
- distutils-r1_python_install_all
- use examples && dodoc -r examples
-}
diff --git a/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild b/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild
index 63eb9f3b7b75..1f42ebe8f21a 100644
--- a/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild
+++ b/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild
@@ -10,12 +10,19 @@ PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="https://scikit-learn.org/stable/"
-SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://scikit-learn.org/stable/
+ https://github.com/scikit-learn/scikit-learn/
+ https://pypi.org/project/scikit-learn/
+"
+SRC_URI="
+ https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+KEYWORDS="amd64 ~arm64 ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
IUSE="examples"
DEPEND="
@@ -35,7 +42,9 @@ BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
"
+EPYTEST_XDIST=1
distutils_enable_tests pytest
+
# For some reason this wants to use urllib to fetch things from the internet
# distutils_enable_sphinx doc \
# dev-python/matplotlib \
@@ -49,9 +58,17 @@ distutils_enable_tests pytest
# dev-python/scikit-image
python_test() {
- # This needs to be run in the install dir
- cd "${WORKDIR}/${P}-${EPYTHON//./_}/install/usr/lib/${EPYTHON}/site-packages/sklearn" || die
- distutils-r1_python_test
+ local EPYTEST_DESELECT=(
+ # test broken with newer scipy, fixed upstream
+ # https://github.com/scikit-learn/scikit-learn/issues/27578
+ manifold/tests/test_locally_linear.py::test_singular_matrix
+ # TODO
+ gaussian_process/kernels.py::sklearn.gaussian_process.kernels.ExpSineSquared
+ )
+
+ rm -rf sklearn || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs sklearn
}
python_install_all() {