summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin44145 -> 44147 bytes
-rw-r--r--sci-libs/m4ri/Manifest3
-rw-r--r--sci-libs/m4ri/files/m4ri-20200125-testfix.patch31
-rw-r--r--sci-libs/m4ri/m4ri-20200125.ebuild4
-rw-r--r--sci-libs/stellarsolver/Manifest1
-rw-r--r--sci-libs/stellarsolver/stellarsolver-2.5.ebuild34
6 files changed, 36 insertions, 37 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index d900c7763595..719908b36034 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/m4ri/Manifest b/sci-libs/m4ri/Manifest
index 64de8ef5334d..ba34d265f870 100644
--- a/sci-libs/m4ri/Manifest
+++ b/sci-libs/m4ri/Manifest
@@ -1,3 +1,4 @@
+AUX m4ri-20200125-testfix.patch 1199 BLAKE2B 07759b0dcff67b1f454738ba4320ca23f19875b62e5414a6dfb3a84db805072c8d8e3901248a0c41d6c13c2837ebbbdc392f89beb398abb4e8050249354fb1b5 SHA512 85a5eec07776b5a5baafdf80c2d249583754dc25baff5b22031f7758e3d3119961444fa0a7c320a44b36cff7da67cfa9ceb7c2a0773bc9f5127c0a761898dabf
DIST m4ri-20200125.tar.gz 511132 BLAKE2B 637dbf7f17b84dc5fc91c9d8f501fa223cfacd687cb953ce3b9c4716e9a6d39318ef168c2ec8a4b5eeb469a4b46abbcd8802aaf694991d82deb20c832843c3ab SHA512 212ea58a93b792c1901f62411b06cd1a2ee60b3506c987e45ded73c146f2fa6baf5461b1dcabf31a5771ab5a44eab050d64714f7a5fca3df2d141d0d80c6c51a
-EBUILD m4ri-20200125.ebuild 1268 BLAKE2B 5d22b54401ac58a895d4d1e341a3297b52afcfe5fd66fee56a0083e7737301fae1273bfb1bcd2f377999d94a663cf39aa5686332d50e1a1a126c2d0256bbd7b7 SHA512 a7286abf7010d66f76966c12074eb5a3b7bab2f361106e8984430a20e0a118a3665839515ae50d4b8027a73291e11044e477739e02a6c89c92270707e4dce661
+EBUILD m4ri-20200125.ebuild 1314 BLAKE2B e0b54317e849334b474dd59364305fad98244199ec3ff51e786fea5818daf4223069205b9d8bce188e0ee824a24125c82593b3925096eebdf8e1a9a7f8ca40bd SHA512 1cf2d3a380b405cf6fd31bec3d8862a2ed7633aa0db0834b687032b0eb8b6d479108255d07c2b7ee8b433b74dc886e3041a771c349ebed4061b29764212ca3bc
MISC metadata.xml 1187 BLAKE2B b5428f60e018c6503ec91f9a13949c6e3571c94474d234317e416fa81e2370d473db9ecb5a1c73306e071673c27b02d57feae552b12f9ce791b426d7a8a488a4 SHA512 a984f783b8bb1971663a75ac655aba7e0a4ddbdb8db6d01105bb6a75711d8e83c9b598076207e1a9619198cca0ed901a5aef64a5443b6efe89a28c2571cdfa71
diff --git a/sci-libs/m4ri/files/m4ri-20200125-testfix.patch b/sci-libs/m4ri/files/m4ri-20200125-testfix.patch
new file mode 100644
index 000000000000..cd45acac4d69
--- /dev/null
+++ b/sci-libs/m4ri/files/m4ri-20200125-testfix.patch
@@ -0,0 +1,31 @@
+From 0643268f316af1150ea2631d27fd1533f5994bb8 Mon Sep 17 00:00:00 2001
+From: "Martin R. Albrecht" <martinralbrecht@googlemail.com>
+Date: Wed, 6 May 2020 13:15:44 +0100
+Subject: [PATCH] don't test things we forbid
+
+fixes #75
+---
+ tests/test_misc.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/tests/test_misc.c b/tests/test_misc.c
+index b1a2e32..0ccddb3 100644
+--- a/tests/test_misc.c
++++ b/tests/test_misc.c
+@@ -130,11 +130,11 @@ int main(int argc, char *argv[]) {
+ status += test_submatrix(2, 130, 1, 1, 2, 130);
+ status += test_submatrix(2, 131, 1, 1, 2, 131);
+
+- status += test_submatrix(2, 63, 1, 1, 1, 63);
+- status += test_submatrix(2, 64, 1, 1, 1, 64);
+- status += test_submatrix(2, 65, 1, 1, 1, 65);
+- status += test_submatrix(2, 66, 1, 1, 1, 66);
+- status += test_submatrix(2, 67, 1, 1, 1, 67);
++ status += test_submatrix(2, 63, 1, 1, 2, 63);
++ status += test_submatrix(2, 64, 1, 1, 2, 64);
++ status += test_submatrix(2, 65, 1, 1, 2, 65);
++ status += test_submatrix(2, 66, 1, 1, 2, 66);
++ status += test_submatrix(2, 67, 1, 1, 2, 67);
+
+ status += test_submatrix(2, 127, 1, 63, 2, 127);
+ status += test_submatrix(2, 128, 1, 64, 2, 128);
diff --git a/sci-libs/m4ri/m4ri-20200125.ebuild b/sci-libs/m4ri/m4ri-20200125.ebuild
index adf6e85765c9..5c4de4a39ebf 100644
--- a/sci-libs/m4ri/m4ri-20200125.ebuild
+++ b/sci-libs/m4ri/m4ri-20200125.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,6 +18,8 @@ BDEPEND="virtual/pkgconfig"
DEPEND="png? ( media-libs/libpng:= )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-testfix.patch" )
+
# NEWS and ChangeLog are empty as of 2020-01-01, and README.md
# didn't make it into the release tarball.
DOCS=( AUTHORS )
diff --git a/sci-libs/stellarsolver/Manifest b/sci-libs/stellarsolver/Manifest
index 8b0d6a0a558d..4056c39debbf 100644
--- a/sci-libs/stellarsolver/Manifest
+++ b/sci-libs/stellarsolver/Manifest
@@ -2,5 +2,4 @@ AUX stellarsolver-2.5-compiler-warning.patch 1046 BLAKE2B a9820195206c698bd31078
AUX stellarsolver-2.5-qsort-warning.patch 10025 BLAKE2B d16f29912b6190e4dc0af6ba307064e1312737eafff211fab1466f2f13af40e9afb6100e728d71d60cae83e8bc88175bf79dedce82f938fd372be22266a21c47 SHA512 a099ef0d47fabec1b9f776a4f901e39daa0231db559837a2f40bf5fa23847513f188bd9292758f5c4f055a5ea62fe03e7c45b8dd129453d41d10b20a510c1d3a
DIST stellarsolver-2.5.tar.gz 23402988 BLAKE2B ec1ab428413104a329128e3e90883884eedf2c031fb4f3f5a8ab7579243a7b7a496579f3127ad0324176cf825d02a417e1538272b931a87090f1373adf0d1239 SHA512 003522ac0b4130e0ca16ccb617743e3716aa2a182ad63abfb901ea0b47c28a745e8ca1e5b7874d17636ff948b1ebc055277557f89a159e425af7d2a64f513fe8
EBUILD stellarsolver-2.5-r1.ebuild 820 BLAKE2B be6a583c400701b7d077947d34ba8c66289d62240165c1e29415e82ed2850e5c7f2d37d98cba8e1efe4a6decf48d5493ca7d4f63497dc3c7b0ec6823c6bad9d2 SHA512 cf94a41d01777c670f938ad59f4de07ca528dd39675c504e9d4d393bdcd61b61c4f778c0d1262d5c29c1fdb20dfd4705c43bad5486ba5cf31ec9ef87d30bcace
-EBUILD stellarsolver-2.5.ebuild 688 BLAKE2B 6a736278e73f986b5b40387de2abc1caada0ae553b98573c06937898f8f152ff7de997d811d4626da58d21464dacecbd8202cb8f341ff397b850412412c3e926 SHA512 3bd5aa128bb70b642e5d7df572ac3b0cae6a0629e85cbc49a9451bbfdd3abecc42bda8b44dc1a1b52d748e0d7a6db0611bac00501e79b115641d0c2f7eb1cdee
MISC metadata.xml 464 BLAKE2B 4d73483b37f92bd6a6a112d27c17ce7c8c0165cb3400f10c3a5ed5a65bcaa6e2e0d892d305834fc813655258173552cdef75431d9798491d0b124de1dbb6f035 SHA512 3cc978f381b4435b05712e69733336ec7e89963d4b236059c21b4bf7f08b899e617243ef5df0e27c2ef21e59197b97fcf414c1964b86b215d0c355c4f88cac77
diff --git a/sci-libs/stellarsolver/stellarsolver-2.5.ebuild b/sci-libs/stellarsolver/stellarsolver-2.5.ebuild
deleted file mode 100644
index c7e235ccd58b..000000000000
--- a/sci-libs/stellarsolver/stellarsolver-2.5.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Cross-platform Sextractor and Astrometry.net-Based internal astrometric solver"
-HOMEPAGE="https://github.com/rlancaste/stellarsolver"
-SRC_URI="https://github.com/rlancaste/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
- sci-libs/cfitsio:=
- sci-libs/gsl:=
- sci-astronomy/wcslib:=
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- # bug #862930
- filter-lto
-
- cmake_src_configure
-}