summaryrefslogtreecommitdiff
path: root/sci-libs/xdmf2/files/xdmf2-1.0_p141226-cmake-3.12.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/xdmf2/files/xdmf2-1.0_p141226-cmake-3.12.patch')
-rw-r--r--sci-libs/xdmf2/files/xdmf2-1.0_p141226-cmake-3.12.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/sci-libs/xdmf2/files/xdmf2-1.0_p141226-cmake-3.12.patch b/sci-libs/xdmf2/files/xdmf2-1.0_p141226-cmake-3.12.patch
new file mode 100644
index 000000000000..14e74bb6108e
--- /dev/null
+++ b/sci-libs/xdmf2/files/xdmf2-1.0_p141226-cmake-3.12.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt 2018-08-30 17:49:07.777815386 +0300
++++ b/CMakeLists.txt 2018-08-30 17:49:49.276706955 +0300
+@@ -6,6 +6,11 @@
+ cmake_policy(SET CMP0015 NEW)
+ endif (POLICY CMP0015)
+
++# Needed for CMake 2.12+
++if(POLICY CMP0077)
++ cmake_policy(SET CMP0077 NEW)
++endif()
++
+ if(MSVC10)
+ SET(CMAKE_RUNTIME_OUTPUT_DIRECTORY_RELEASE ${CMAKE_BINARY_DIR})
+ SET(CMAKE_LIBRARY_OUTPUT_DIRECTORY_RELEASE ${CMAKE_BINARY_DIR})