summaryrefslogtreecommitdiff
path: root/sci-libs/voro++/voro++-0.4.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/voro++/voro++-0.4.6-r1.ebuild')
-rw-r--r--sci-libs/voro++/voro++-0.4.6-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-libs/voro++/voro++-0.4.6-r1.ebuild b/sci-libs/voro++/voro++-0.4.6-r1.ebuild
new file mode 100644
index 000000000000..1f1aa5a860ae
--- /dev/null
+++ b/sci-libs/voro++/voro++-0.4.6-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A 3D Voronoi cell software library"
+HOMEPAGE="http://math.lbl.gov/voro++/"
+SRC_URI="${HOMEPAGE}/download/dir/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_configure() {
+ mycmakeargs=( -DLIB=$(get_libdir) )
+ cmake-utils_src_configure
+}