summaryrefslogtreecommitdiff
path: root/sci-libs/transformers/transformers-4.34.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/transformers/transformers-4.34.1-r1.ebuild')
-rw-r--r--sci-libs/transformers/transformers-4.34.1-r1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/sci-libs/transformers/transformers-4.34.1-r1.ebuild b/sci-libs/transformers/transformers-4.34.1-r1.ebuild
deleted file mode 100644
index 482c1835adb8..000000000000
--- a/sci-libs/transformers/transformers-4.34.1-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..12} )
-inherit distutils-r1
-
-DESCRIPTION="State-of-the-art Machine Learning for JAX, PyTorch and TensorFlow"
-HOMEPAGE="
- https://pypi.org/project/transformers/
- https://huggingface.co/
-"
-SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="test" # Need some modules, not yet packaged
-
-RDEPEND="
- dev-python/filelock[${PYTHON_USEDEP}]
- sci-libs/huggingface_hub[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/regex[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- sci-libs/safetensors[${PYTHON_USEDEP}]
- sci-libs/tokenizers[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest