summaryrefslogtreecommitdiff
path: root/sci-libs/stellarsolver/stellarsolver-2.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/stellarsolver/stellarsolver-2.5-r1.ebuild')
-rw-r--r--sci-libs/stellarsolver/stellarsolver-2.5-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/stellarsolver/stellarsolver-2.5-r1.ebuild b/sci-libs/stellarsolver/stellarsolver-2.5-r1.ebuild
new file mode 100644
index 000000000000..f60a2a9b7daf
--- /dev/null
+++ b/sci-libs/stellarsolver/stellarsolver-2.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Cross-platform Sextractor and Astrometry.net-Based internal astrometric solver"
+HOMEPAGE="https://github.com/rlancaste/stellarsolver"
+SRC_URI="https://github.com/rlancaste/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ sci-libs/cfitsio:=
+ sci-libs/gsl:=
+ sci-astronomy/wcslib:=
+"
+DEPEND="${RDEPEND}"
+
+# https://github.com/rlancaste/stellarsolver/issues/108
+PATCHES=( "${FILESDIR}"/${P}-{qsort,compiler}-warning.patch ) # git master
+
+src_configure() {
+ # bug #862930
+ filter-lto
+
+ cmake_src_configure
+}