summaryrefslogtreecommitdiff
path: root/sci-libs/spqr/spqr-2.0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/spqr/spqr-2.0.9.ebuild')
-rw-r--r--sci-libs/spqr/spqr-2.0.9.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/sci-libs/spqr/spqr-2.0.9.ebuild b/sci-libs/spqr/spqr-2.0.9.ebuild
index ae9b6c3adc4b..72475fd658a1 100644
--- a/sci-libs/spqr/spqr-2.0.9.ebuild
+++ b/sci-libs/spqr/spqr-2.0.9.ebuild
@@ -9,8 +9,8 @@ SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc partition static-libs tbb"
+KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="doc partition tbb"
BDEPEND="virtual/pkgconfig
doc? ( virtual/latex-base )"
@@ -18,7 +18,8 @@ BDEPEND="virtual/pkgconfig
# USE=lapack, and cholmod has to have partition support if spqr is going
# to have it (the ./configure script for spqr checks this). Note that
# spqr links to metis directly, too.
-DEPEND="virtual/lapack
+DEPEND="
+ virtual/lapack
>=sci-libs/cholmod-2[lapack,partition?]
partition? ( >=sci-libs/metis-5.1.0 )
tbb? ( dev-cpp/tbb )"
@@ -26,8 +27,15 @@ RDEPEND="${DEPEND}"
src_configure() {
econf \
+ --disable-static \
$(use_with doc) \
- $(use_enable static-libs static) \
$(use_with partition) \
$(use_with tbb)
}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}