summaryrefslogtreecommitdiff
path: root/sci-libs/spqr/spqr-2.0.9-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/spqr/spqr-2.0.9-r3.ebuild')
-rw-r--r--sci-libs/spqr/spqr-2.0.9-r3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-libs/spqr/spqr-2.0.9-r3.ebuild b/sci-libs/spqr/spqr-2.0.9-r3.ebuild
index b63bdbe966ea..f12c0cec5481 100644
--- a/sci-libs/spqr/spqr-2.0.9-r3.ebuild
+++ b/sci-libs/spqr/spqr-2.0.9-r3.ebuild
@@ -1,15 +1,17 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit libtool
+
DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm arm64 ~hppa ~loong ~ppc ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc partition tbb"
BDEPEND="virtual/pkgconfig
@@ -25,6 +27,11 @@ DEPEND="
tbb? ( <dev-cpp/tbb-2021:= )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf \
--disable-static \