summaryrefslogtreecommitdiff
path: root/sci-libs/shapely
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/shapely')
-rw-r--r--sci-libs/shapely/Manifest4
-rw-r--r--sci-libs/shapely/files/shapely-1.7.1-tests-support-geos-3.9.patch61
-rw-r--r--sci-libs/shapely/metadata.xml19
-rw-r--r--sci-libs/shapely/shapely-1.7.1-r1.ebuild31
4 files changed, 0 insertions, 115 deletions
diff --git a/sci-libs/shapely/Manifest b/sci-libs/shapely/Manifest
deleted file mode 100644
index 63bf3f81c96a..000000000000
--- a/sci-libs/shapely/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX shapely-1.7.1-tests-support-geos-3.9.patch 2130 BLAKE2B 2785926f41a8d9486b9591616acf1f9b2dd76c2b009a7a51fefcb664733b304e7fc59b247a87fa36f4b4301132f157a16153f78dc68c2102901c4eea46c020ba SHA512 64c5ecd44ee7b6020e9605825b8af78ba0dfcaa5b0358c8f76af4104869ce027eb059331fa8c488add3ac1e360e41f46346d24e702c54858fe2f9bbef0b929a6
-DIST shapely-1.7.1.tar.gz 293368 BLAKE2B 14d9cb0c2b486a3a20b71c0cde7260ec357287ea020352c0320eea07b91674605bdcd22512b33c5ac5a71b89c3d811946f8dd6d3b90c61398203a4c68f30d067 SHA512 72070437960a8c1cf6504b5f4ccc8ec509f87fb6a90178e291aff14889f5add89f9ed4f7e9a19799ce0835c1aea3f0241eaa6efd4d8ea5b879f2167f7c1de50a
-EBUILD shapely-1.7.1-r1.ebuild 766 BLAKE2B c22e5964f5c5b6d7b942dad03496705adfe651400357381f07c0032c82da5ac7e6ed8c1db66f308dff3c022f26addb45623920b4d3c28a372df504b74b7b164e SHA512 d8cd42d1644137de5a1af160c067c66d2681b538db456955aebc3495ddbdf9f07d76478f142d66b61a2c5df1f2e7540d462de266e5450c2627f2722a0a834270
-MISC metadata.xml 897 BLAKE2B 1e8c9122f9b88da6698151ad71082ddf7e6a4d7f2a6710a21e6851607afb2e48425e080d6adc40d1d27d18878a894bcc6aaf845d702adc2c83db1c4b7f8be3fd SHA512 e17253f9112e5e5e327ba66f22f2dc5dc8dc763d79870583e7d4b82c76f0429bd6431ba0845f7cb349feaf4dfc5da86492d866aba47cf91926c442c0bbb6eaa5
diff --git a/sci-libs/shapely/files/shapely-1.7.1-tests-support-geos-3.9.patch b/sci-libs/shapely/files/shapely-1.7.1-tests-support-geos-3.9.patch
deleted file mode 100644
index 18b6c5ad9a46..000000000000
--- a/sci-libs/shapely/files/shapely-1.7.1-tests-support-geos-3.9.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/tests/test_svg.py b/tests/test_svg.py
---- a/tests/test_svg.py (revision 56c0f97a80e75308cf62e0bc4883238c10f56fdf)
-+++ b/tests/test_svg.py (date 1615044742785)
-@@ -174,7 +174,8 @@
- self.assertSVG(GeometryCollection(), '<g />')
- # Valid
- self.assertSVG(
-- Point(7, 3).union(LineString([(4, 2), (8, 4)])),
-+ GeometryCollection(
-+ [Point(7, 3), LineString([(4, 2), (8, 4)])]),
- '<g><circle cx="7.0" cy="3.0" r="3.0" stroke="#555555" '
- 'stroke-width="1.0" fill="#66cc99" opacity="0.6" />'
- '<polyline fill="none" stroke="#66cc99" stroke-width="2.0" '
---- a/tests/test_wkb.py (revision 56c0f97a80e75308cf62e0bc4883238c10f56fdf)
-+++ b/tests/test_wkb.py (date 1615044817079)
-@@ -1,6 +1,11 @@
-+import binascii
-+
-+import pytest
-+
-+from shapely import wkt
- from shapely.wkb import dumps, loads
- from shapely.geometry import Point
--import binascii
-+from shapely.geos import geos_version
-
-
- def bin2hex(value):
-@@ -49,3 +54,20 @@
- # replace geometry srid with another
- result = dumps(geom, srid=27700)
- assert bin2hex(result) == "0101000020346C0000333333333333F33F3333333333330B40"
-+
-+
-+requires_geos_39 = pytest.mark.xfail(
-+ geos_version < (3, 9, 0), reason="GEOS >= 3.9.0 is required", strict=True)
-+
-+
-+@requires_geos_39
-+def test_point_empty():
-+ g = wkt.loads("POINT EMPTY")
-+ assert g.wkb_hex == "0101000000000000000000F87F000000000000F87F"
-+
-+
-+@requires_geos_39
-+def test_point_z_empty():
-+ g = wkt.loads("POINT Z EMPTY")
-+ assert g.wkb_hex == \
-+ "0101000080000000000000F87F000000000000F87F000000000000F87F"
-diff --git a/shapely/geos.py b/shapely/geos.py
---- a/shapely/geos.py (revision 56c0f97a80e75308cf62e0bc4883238c10f56fdf)
-+++ b/shapely/geos.py (date 1615044673942)
-@@ -84,7 +84,7 @@
- 'libgeos_c.so.1',
- 'libgeos_c.so',
- ]
-- _lgeos = load_dll('geos_c', fallbacks=alt_paths)
-+ _lgeos = load_dll('libgeos_c', fallbacks=alt_paths)
- # Necessary for environments with only libc.musl
- c_alt_paths = [
- 'libc.musl-x86_64.so.1'
diff --git a/sci-libs/shapely/metadata.xml b/sci-libs/shapely/metadata.xml
deleted file mode 100644
index fb27f29d1c11..000000000000
--- a/sci-libs/shapely/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>3dprint@gentoo.org</email>
- <name>Gentoo 3D Printer Project</name>
- </maintainer>
- <longdescription>
- Shapely is a BSD-licensed Python package for manipulation and analysis of planar geometric objects.
- It is based on the widely deployed GEOS (the engine of PostGIS) and JTS (from which GEOS is ported) libraries.
- Shapely is not concerned with data formats or coordinate systems, but can be readily integrated with packages that are.
- </longdescription>
- <upstream>
- <bugs-to>https://github.com/Toblerity/Shapely/issues</bugs-to>
- <doc>https://shapely.readthedocs.io</doc>
- <remote-id type="github">Toblerity/Shapely</remote-id>
- <remote-id type="pypi">Shapely</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-libs/shapely/shapely-1.7.1-r1.ebuild b/sci-libs/shapely/shapely-1.7.1-r1.ebuild
deleted file mode 100644
index 749e53b1ac3e..000000000000
--- a/sci-libs/shapely/shapely-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Geometric objects, predicates, and operations"
-HOMEPAGE="https://pypi.org/project/Shapely/ https://github.com/Toblerity/Shapely"
-SRC_URI="https://github.com/Toblerity/Shapely/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-DEPEND=">=sci-libs/geos-3.9"
-RDEPEND="${DEPEND}
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="${DEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-tests-support-geos-3.9.patch"
-)
-
-distutils_enable_tests --install pytest
-distutils_enable_sphinx docs dev-python/matplotlib