summaryrefslogtreecommitdiff
path: root/sci-libs/scikit-learn
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/scikit-learn')
-rw-r--r--sci-libs/scikit-learn/Manifest4
-rw-r--r--sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild64
-rw-r--r--sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild29
3 files changed, 24 insertions, 73 deletions
diff --git a/sci-libs/scikit-learn/Manifest b/sci-libs/scikit-learn/Manifest
index 843a753b4fed..93c832da8178 100644
--- a/sci-libs/scikit-learn/Manifest
+++ b/sci-libs/scikit-learn/Manifest
@@ -1,5 +1,3 @@
-DIST scikit-learn-1.1.2.gh.tar.gz 7104556 BLAKE2B e67e1deddf5a1134b57a146e8271a406cb257ffc92c9719e90f5b9d98e711b68bc67e3367660ecaad61aaec1794bb8999b4dd00b7d56e21eca8fcb2ee72cc9aa SHA512 58789c1e607d7de3339fa3b8928553ca96cef93e8da8fd13612aa78e5ebde8e6a55e3bf7845f9a45b78ed77da6a219d08d2c26318b602f937e0e3debd239293e
DIST scikit-learn-1.3.2.gh.tar.gz 7650823 BLAKE2B 170699917f46d6d3f4b9ebc314bc1ec45687dad0a4aec5d2cee6e288b5dbe508bad6dd80406501f289a33593c6482067393e9dc28155f85a4872a34523bf4199 SHA512 a3799e9b39b755a50ba225f836904a378f7d83a08274c614d0485e4d4d4a7b0c7adba2dbb6612f2ccb4e5167f872214a2853eff69d767dc70f52369bda7a230b
-EBUILD scikit-learn-1.1.2.ebuild 1630 BLAKE2B 75231c2493783f4cfb3c5979cd813357fda3bf8f2f435963d8c788665eba387a8351a5630a85d43699b63a63edf7cde653cafbba23f1373cb57b0f9d909886cb SHA512 95e49f1dfb0c032302bd5e9b6ce7773c3a099a3311d2aaf398eff68c93531278a010c1768bb25ca17e76067485fb18915766ecfa8ad71fc173b73d7e1769da02
-EBUILD scikit-learn-1.3.2-r1.ebuild 1606 BLAKE2B b9cacd1e25aeeccdee743009ea49001cceedf40fd0cbfdfc0a1978457b70c77e8a47e5679b7913e10bb990a553bb29a4ea9eee187f88afcb2afaecc84a8a456f SHA512 c1d7c3db9a10c87fe3c2e8e265f27ebc3dd9945cfd55ee423c2870fb217a96e4a0cef8c288b98362e793005d34fc84e11065ad74e29fb9b4f50251208d631bb1
+EBUILD scikit-learn-1.3.2-r1.ebuild 1937 BLAKE2B 633a70b5f27f2ad9a3e1ccbc0f560aa3e4e41768827d2fe7f89009712c105829a545de79b2acdb7e45d7ff4f83d555ba138f4bbff76038474996e2fa8eec3b78 SHA512 b09e1c642450e0bc10b213a3171962dd262f550926424c10de11711597c70c0915a140a30ffe6f255c5751bce9938b7874a0b9feebc51d71d042830f1991e7b6
MISC metadata.xml 614 BLAKE2B b5425c2d022592581647c9b97c0ab22bfc2afe347b2e5ea22f141245238f145322f39406c62318ba1e6af1462b2691267b39976bfde38faaf1d28b1d29c4e015 SHA512 74ac79123848bc385c29fcfdc4a1e780529dda685c1deb5eb722f5d4919ee6ac9d80798d52c4af0be0cc8dbbaea3784963dd97e2b7c1258cc2f5605b0bc8907a
diff --git a/sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild b/sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild
deleted file mode 100644
index 19c4f027d4bc..000000000000
--- a/sci-libs/scikit-learn/scikit-learn-1.1.2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="https://scikit-learn.org/stable/"
-SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
-IUSE="examples"
-
-# Fatal Python error: Segmentation fault
-RESTRICT="test"
-
-DEPEND="
- virtual/blas:=
- virtual/cblas:=
-"
-RDEPEND="
- ${DEPEND}
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/joblib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/threadpoolctl[${PYTHON_USEDEP}]
-"
-# <cython-3: https://bugs.gentoo.org/911369
-BDEPEND="
- <dev-python/cython-3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-# For some reason this wants to use urllib to fetch things from the internet
-# distutils_enable_sphinx doc \
-# dev-python/matplotlib \
-# dev-python/memory-profiler \
-# dev-python/numpydoc \
-# dev-python/pandas \
-# dev-python/pillow \
-# dev-python/seaborn \
-# dev-python/sphinx-gallery \
-# dev-python/sphinx-prompt \
-# dev-python/scikit-image
-
-python_test() {
- # This needs to be run in the install dir
- cd "${WORKDIR}/${P}-${EPYTHON//./_}/install/usr/lib/${EPYTHON}/site-packages/sklearn" || die
- distutils-r1_python_test
-}
-
-python_install_all() {
- find "${S}" -name \*LICENSE.txt -delete || die
- distutils-r1_python_install_all
- use examples && dodoc -r examples
-}
diff --git a/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild b/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild
index 63eb9f3b7b75..1f42ebe8f21a 100644
--- a/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild
+++ b/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild
@@ -10,12 +10,19 @@ PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="https://scikit-learn.org/stable/"
-SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://scikit-learn.org/stable/
+ https://github.com/scikit-learn/scikit-learn/
+ https://pypi.org/project/scikit-learn/
+"
+SRC_URI="
+ https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+KEYWORDS="amd64 ~arm64 ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
IUSE="examples"
DEPEND="
@@ -35,7 +42,9 @@ BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
"
+EPYTEST_XDIST=1
distutils_enable_tests pytest
+
# For some reason this wants to use urllib to fetch things from the internet
# distutils_enable_sphinx doc \
# dev-python/matplotlib \
@@ -49,9 +58,17 @@ distutils_enable_tests pytest
# dev-python/scikit-image
python_test() {
- # This needs to be run in the install dir
- cd "${WORKDIR}/${P}-${EPYTHON//./_}/install/usr/lib/${EPYTHON}/site-packages/sklearn" || die
- distutils-r1_python_test
+ local EPYTEST_DESELECT=(
+ # test broken with newer scipy, fixed upstream
+ # https://github.com/scikit-learn/scikit-learn/issues/27578
+ manifold/tests/test_locally_linear.py::test_singular_matrix
+ # TODO
+ gaussian_process/kernels.py::sklearn.gaussian_process.kernels.ExpSineSquared
+ )
+
+ rm -rf sklearn || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs sklearn
}
python_install_all() {