summaryrefslogtreecommitdiff
path: root/sci-libs/rocSPARSE
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/rocSPARSE')
-rw-r--r--sci-libs/rocSPARSE/Manifest1
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild138
2 files changed, 139 insertions, 0 deletions
diff --git a/sci-libs/rocSPARSE/Manifest b/sci-libs/rocSPARSE/Manifest
index c4b70a6382cc..bd17fb733d1d 100644
--- a/sci-libs/rocSPARSE/Manifest
+++ b/sci-libs/rocSPARSE/Manifest
@@ -26,5 +26,6 @@ DIST rocSPARSE_shipsec1.tar.gz 22175245 BLAKE2B f1d34482b8c3d3ee48033097d7d6f9b6
DIST rocSPARSE_sme3Dc.tar.gz 42483568 BLAKE2B f0d16b58f6ea28e67727637697a812a0b10d524c73aeb82f702411b9ebaea3670780e762ed0701aae80c6829e950233f74555523ef2d6c5740b007c7a65c03d4 SHA512 c5a0be2db919a45310a73ea1dd96d0d30168135f887a8c5c3d7ca11e2c3d12ea7d1331be20968d0135bd18da4ef2b043db68eeb7567b6f0f8daf782b87083c3a
DIST rocSPARSE_webbase-1M.tar.gz 11360460 BLAKE2B 01b1d06adb5fb32fa402ed888d25a7e52a34779b078fc2e21c60e688d03579bb4ca8694f5ee4a824f7859952d55590a1fd9449dc80d6fe894d7b662b918882d4 SHA512 6401a965b8f6dd5392879956fde3c94f77fe1801a4a43428c03b6d639031575c647eab47b1babe53f4ecc2c3b8fc183e8339536b78dcd0d94ce62bfedd87c161
EBUILD rocSPARSE-4.0.0-r1.ebuild 1166 BLAKE2B fc45fdaaf8d5f20afcc0d477eac01d30100a3ac3355ddae786ee934f46ef55b4f6ac3b284875fc905f75452cbfbb655ad4cfb9f916905e1a6091e8b97a14f141 SHA512 221e3aea6c45e7d7a6edc3b96db32ed9d2deb040f1f4cafa9cbb139a146aa7500d4619e6e8db39683fed9c0bc34053dc8ede22525340457c1774f6ea90297a98
+EBUILD rocSPARSE-4.3.0-r1.ebuild 5002 BLAKE2B 61c889cc81ceccc5b628bddef68c5a5df2d789bb6c30a2445ee47d7e4271c8e8a3363fbc523b35c9df9d66dd15292a490f4332ff3f5b296d4eb42a1b0c5468ec SHA512 f7447eed601b528a132a406df80056f760ff09fc67c7b32bc453527b5429df1bb1f42ddd34ab647e04aadf44760d4916de0d6087bd8a9efc09d32858eaafc8b1
EBUILD rocSPARSE-4.3.0.ebuild 4557 BLAKE2B 0ca53de6d519bc369b25ba573c6aacc5adf7a554bad514698a719c4794af236909cc4be8650bf84327ed6965d7e86ca9a96fd31240c06a1e49723f7b303001e5 SHA512 f746cda86084c8e6ccfc7ff9635332440663ffec3082ddb78052204f5210110a81edc0fb19d6616166bea1962d20c746e0ee92160468aa670433bfd1d567ba9f
MISC metadata.xml 695 BLAKE2B db1c67ff216cd9c9a972c9b388f85f6e762e0a7bddffca1336219ce6ebe39f6a841da4c8c78084d91f48a5bb6a26ad0047a2a1a60915da5110b3a41977f3b641 SHA512 2f246ec382d78e414a00aedcd7a2c871ccf5b74d25d160a0f7d6012feb51c6c12861b5152cac32d3e46d0d1acea7e8b10f42f4b501abb9d778cd3c886331f59c
diff --git a/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild b/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..a196780e222e
--- /dev/null
+++ b/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit cmake python-any-r1 toolchain-funcs
+
+DESCRIPTION="Basic Linear Algebra Subroutines for sparse computation"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocSPARSE"
+
+SRC_URI="https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-${PV}.tar.gz -> rocSPARSE-${PV}.tar.gz
+test? (
+https://sparse.tamu.edu/MM/SNAP/amazon0312.tar.gz -> ${PN}_amazon0312.tar.gz
+https://sparse.tamu.edu/MM/Muite/Chebyshev4.tar.gz -> ${PN}_Chebyshev4.tar.gz
+https://sparse.tamu.edu/MM/FEMLAB/sme3Dc.tar.gz -> ${PN}_sme3Dc.tar.gz
+https://sparse.tamu.edu/MM/Williams/webbase-1M.tar.gz -> ${PN}_webbase-1M.tar.gz
+https://sparse.tamu.edu/MM/Bova/rma10.tar.gz -> ${PN}_rma10.tar.gz
+https://sparse.tamu.edu/MM/JGD_BIBD/bibd_22_8.tar.gz -> ${PN}_bibd_22_8.tar.gz
+https://sparse.tamu.edu/MM/Williams/mac_econ_fwd500.tar.gz -> ${PN}_mac_econ_fwd500.tar.gz
+https://sparse.tamu.edu/MM/Williams/mc2depi.tar.gz -> ${PN}_mc2depi.tar.gz
+https://sparse.tamu.edu/MM/Hamm/scircuit.tar.gz -> ${PN}_scircuit.tar.gz
+https://sparse.tamu.edu/MM/Sandia/ASIC_320k.tar.gz -> ${PN}_ASIC_320k.tar.gz
+https://sparse.tamu.edu/MM/GHS_psdef/bmwcra_1.tar.gz -> ${PN}_bmwcra_1.tar.gz
+https://sparse.tamu.edu/MM/HB/nos1.tar.gz -> ${PN}_nos1.tar.gz
+https://sparse.tamu.edu/MM/HB/nos2.tar.gz -> ${PN}_nos2.tar.gz
+https://sparse.tamu.edu/MM/HB/nos3.tar.gz -> ${PN}_nos3.tar.gz
+https://sparse.tamu.edu/MM/HB/nos4.tar.gz -> ${PN}_nos4.tar.gz
+https://sparse.tamu.edu/MM/HB/nos5.tar.gz -> ${PN}_nos5.tar.gz
+https://sparse.tamu.edu/MM/HB/nos6.tar.gz -> ${PN}_nos6.tar.gz
+https://sparse.tamu.edu/MM/HB/nos7.tar.gz -> ${PN}_nos7.tar.gz
+https://sparse.tamu.edu/MM/DNVS/shipsec1.tar.gz -> ${PN}_shipsec1.tar.gz
+https://sparse.tamu.edu/MM/Cote/mplate.tar.gz -> ${PN}_mplate.tar.gz
+https://sparse.tamu.edu/MM/Bai/qc2534.tar.gz -> ${PN}_qc2534.tar.gz
+https://sparse.tamu.edu/MM/Chevron/Chevron2.tar.gz -> ${PN}_Chevron2.tar.gz
+https://sparse.tamu.edu/MM/Chevron/Chevron3.tar.gz -> ${PN}_Chevron3.tar.gz
+https://sparse.tamu.edu/MM/Chevron/Chevron4.tar.gz -> ${PN}_Chevron4.tar.gz
+)"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE="benchmark test"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="dev-util/hip:${SLOT}
+ sci-libs/rocPRIM:${SLOT}"
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ dev-cpp/gtest
+ $(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
+)
+benchmark? ( app-admin/chrpath )
+"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/rocSPARSE-rocm-${PV}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.3.0-remove-matrices-unpacking.patch" )
+
+python_check_deps() {
+ if use test; then
+ has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
+ fi
+}
+
+src_prepare() {
+ eapply_user
+ sed -e "s/PREFIX rocsparse//" \
+ -e "/<INSTALL_INTERFACE/s,include,include/rocsparse," \
+ -e "/rocm_install_symlink_subdir(rocsparse)/d" \
+ -e "s:rocsparse/include:include/rocsparse:" \
+ -i "${S}/library/CMakeLists.txt" || die
+
+ # remove GIT dependency
+ sed -e "/find_package(Git/d" -i cmake/Dependencies.cmake || die
+
+ # use python interpreter specifyied by python-any-r1
+ sed -e "/COMMAND ..\/common\/rocsparse_gentest.py/s,COMMAND ,COMMAND ${EPYTHON} ," -i clients/tests/CMakeLists.txt || die
+
+ # Test need download data from https://sparse.tamu.edu (or other mirror site), check MD5, unpack and convert them into csr format
+ # This process is handled default by ${S}/cmake/ClientMatrices.cmake, but should be the responsibility of portage.
+ if use test; then
+ mkdir -p "${BUILD_DIR}"/matrices
+ # compile and use the mtx2csr converter. Do not use any optimization flags, because it causes error!
+ ebegin "$(tc-getCXX) deps/convert.cpp -o deps/convert"
+ $(tc-getCXX) deps/convert.cpp -o deps/convert
+ eend $?
+ find "${WORKDIR}" -maxdepth 2 -regextype egrep -regex ".*/(.*)/\1\.mtx" -print0 |
+ while IFS= read -r -d '' mtxfile; do
+ destination=${BUILD_DIR}/matrices/$(basename -s '.mtx' ${mtxfile}).csr
+ ebegin "Converting ${mtxfile} to ${destination}"
+ deps/convert ${mtxfile} ${destination}
+ eend $?
+ done
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Grant access to the device to omit a sandbox violation
+ addwrite /dev/kfd
+ addpredict /dev/dri/
+
+ # Compiler to use
+ export CXX=hipcc
+
+ local mycmakeargs=(
+ -DBUILD_CLIENTS_SAMPLES=OFF
+ -DCMAKE_INSTALL_INCLUDEDIR="include/rocsparse"
+ -DCMAKE_SKIP_RPATH="ON"
+ -DBUILD_CLIENTS_TESTS=$(usex test ON OFF)
+ -DBUILD_CLIENTS_BENCHMARKS=$(usex benchmark ON OFF)
+ ${AMDGPU_TARGETS+-DAMDGPU_TARGETS="${AMDGPU_TARGETS}"}
+ -D__skip_rocmclang="ON" ## fix cmake-3.21 configuration issue caused by officialy support programming language "HIP"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ addwrite /dev/kfd
+ addwrite /dev/dri/
+ cd "${BUILD_DIR}/clients/staging" || die
+ ./rocsparse-test || die
+}
+
+src_install() {
+ cmake_src_install
+
+ if use benchmark; then
+ local rocsparse_bench="${BUILD_DIR}/clients/staging/rocsparse-bench"
+ chrpath -d "${rocsparse_bench}" || die
+ dobin "${rocsparse_bench}"
+ fi
+}