summaryrefslogtreecommitdiff
path: root/sci-libs/opencascade/opencascade-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/opencascade/opencascade-9999.ebuild')
-rw-r--r--sci-libs/opencascade/opencascade-9999.ebuild46
1 files changed, 26 insertions, 20 deletions
diff --git a/sci-libs/opencascade/opencascade-9999.ebuild b/sci-libs/opencascade/opencascade-9999.ebuild
index e3da366e699f..94a2d018ce23 100644
--- a/sci-libs/opencascade/opencascade-9999.ebuild
+++ b/sci-libs/opencascade/opencascade-9999.ebuild
@@ -31,7 +31,7 @@ fi
LICENSE="|| ( Open-CASCADE-LGPL-2.1-Exception-1.0 LGPL-2.1 )"
SLOT="0/$(ver_cut 1-2)"
-IUSE="X debug doc examples ffmpeg freeimage freetype gles2-only +gui jemalloc json +opengl optimize tbb test testprograms tk vtk"
+IUSE="X debug doc examples ffmpeg freeimage freetype gles2-only inspector jemalloc json +opengl optimize tbb test testprograms tk vtk"
REQUIRED_USE="
?? ( optimize tbb )
@@ -57,20 +57,26 @@ RDEPEND="
X? (
x11-libs/libX11
)
- gui? (
- examples? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtquickcontrols2:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- )
+ examples? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
)
ffmpeg? ( <media-video/ffmpeg-5:= )
freeimage? ( media-libs/freeimage )
+ inspector? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
jemalloc? ( dev-libs/jemalloc )
tbb? ( dev-cpp/tbb:= )
vtk? (
+ dev-lang/tk:=
sci-libs/vtk:=[rendering]
tbb? (
sci-libs/vtk:=[tbb,-cuda]
@@ -84,8 +90,8 @@ DEPEND="
"
BDEPEND="
doc? ( app-text/doxygen[dot] )
- gui? (
- examples? ( dev-qt/linguist-tools:5 )
+ inspector? (
+ dev-qt/linguist-tools:5
)
test? ( dev-tcltk/thread )
"
@@ -97,9 +103,12 @@ PATCHES=(
"${FILESDIR}/${PN}-7.7.0-avoid-pre-stripping-binaries.patch"
"${FILESDIR}/${PN}-7.7.0-build-against-vtk-9.2.patch"
"${FILESDIR}/${PN}-7.7.0-musl.patch"
+ "${FILESDIR}/${PN}-7.7.0-tbb-detection.patch"
"${FILESDIR}/${PN}-7.7.0-jemalloc-lib-type.patch"
"${FILESDIR}/${PN}-7.8.0-cmake-min-version.patch"
"${FILESDIR}/${PN}-7.8.0-tests.patch"
+ "${FILESDIR}/${PN}-7.8.0-jemalloc-noexcept.patch"
+ "${FILESDIR}/${PN}-7.8.1-vtk_components.patch"
)
src_unpack() {
@@ -145,7 +154,7 @@ src_configure() {
-DBUILD_SOVERSION_NUMBERS=2
-DBUILD_DOC_Overview="$(usex doc)"
- -DBUILD_Inspector="$(usex gui)"
+ -DBUILD_Inspector="$(usex inspector)"
-DBUILD_ENABLE_FPE_SIGNAL_HANDLER="$(usex debug)"
-DBUILD_USE_PCH="no"
@@ -192,7 +201,10 @@ src_configure() {
if ! use jemalloc && ! use tbb; then
mycmakeargs+=( -DUSE_MMGR_TYPE=NATIVE )
elif use jemalloc && ! use tbb; then
- mycmakeargs+=( -DUSE_MMGR_TYPE=JEMALLOC )
+ mycmakeargs+=(
+ -DUSE_MMGR_TYPE=JEMALLOC
+ -D3RDPARTY_JEMALLOC_INCLUDE_DIR="${ESYSROOT}/usr/include/jemalloc"
+ )
elif ! use jemalloc && use tbb; then
mycmakeargs+=( -DUSE_MMGR_TYPE=TBB )
elif use jemalloc && use tbb; then
@@ -206,19 +218,13 @@ src_configure() {
)
fi
- if use gui; then
+ if use examples || use inspector; then
mycmakeargs+=(
-D3RDPARTY_QT_DIR="${ESYSROOT}/usr"
-DBUILD_SAMPLES_QT="$(usex examples)"
)
fi
- if use jemalloc; then
- mycmakeargs+=(
- -D3RDPARTY_JEMALLOC_INCLUDE_DIR="${ESYSROOT}/usr/include/jemalloc"
- )
- fi
-
if use tbb; then
mycmakeargs+=(
-D3RDPARTY_TBB_DIR="${ESYSROOT}/usr"