summaryrefslogtreecommitdiff
path: root/sci-libs/opencascade/opencascade-7.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/opencascade/opencascade-7.7.2.ebuild')
-rw-r--r--sci-libs/opencascade/opencascade-7.7.2.ebuild41
1 files changed, 13 insertions, 28 deletions
diff --git a/sci-libs/opencascade/opencascade-7.7.2.ebuild b/sci-libs/opencascade/opencascade-7.7.2.ebuild
index 384a99eaaf44..606592c2b231 100644
--- a/sci-libs/opencascade/opencascade-7.7.2.ebuild
+++ b/sci-libs/opencascade/opencascade-7.7.2.ebuild
@@ -32,11 +32,12 @@ fi
LICENSE="|| ( Open-CASCADE-LGPL-2.1-Exception-1.0 LGPL-2.1 )"
SLOT="0/$(ver_cut 1-2)"
-IUSE="X debug doc examples ffmpeg freeimage freetype gles2-only +gui jemalloc json +opengl optimize tbb test testprograms tk vtk"
+IUSE="X debug doc examples ffmpeg freeimage freetype gles2-only gui json +opengl optimize tbb test testprograms tk vtk"
REQUIRED_USE="
?? ( optimize tbb )
?? ( opengl gles2-only )
+ examples? ( gui )
test? ( freeimage json opengl )
"
@@ -59,17 +60,14 @@ RDEPEND="
x11-libs/libX11
)
gui? (
- examples? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtquickcontrols2:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- )
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
)
ffmpeg? ( <media-video/ffmpeg-5:= )
freeimage? ( media-libs/freeimage )
- jemalloc? ( dev-libs/jemalloc )
tbb? ( dev-cpp/tbb:= )
vtk? (
sci-libs/vtk:=[rendering]
@@ -86,7 +84,7 @@ DEPEND="
BDEPEND="
doc? ( app-text/doxygen[dot] )
gui? (
- examples? ( dev-qt/linguist-tools:5 )
+ dev-qt/linguist-tools:5
)
test? ( dev-tcltk/thread )
"
@@ -98,7 +96,7 @@ PATCHES=(
"${FILESDIR}/${PN}-7.7.0-avoid-pre-stripping-binaries.patch"
"${FILESDIR}/${PN}-7.7.0-build-against-vtk-9.2.patch"
"${FILESDIR}/${PN}-7.7.0-musl.patch"
- "${FILESDIR}/${PN}-7.7.0-jemalloc-lib-type.patch"
+ "${FILESDIR}/${PN}-7.7.0-tbb-detection.patch"
"${FILESDIR}/${PN}-7.8.0-cmake-min-version.patch"
"${FILESDIR}/${PN}-7.8.0-tests.patch"
)
@@ -178,23 +176,13 @@ src_configure() {
# no package in tree
-DUSE_OPENVR="no"
-DUSE_RAPIDJSON="$(usex json)"
+ -DUSE_QT="$(usex gui)"
-DUSE_TBB="$(usex tbb)"
-DUSE_TK="$(usex tk)"
-DUSE_VTK="$(usex vtk)"
-DUSE_XLIB="$(usex X)"
)
- # Select using memory manager tool.
- if ! use jemalloc && ! use tbb; then
- mycmakeargs+=( -DUSE_MMGR_TYPE=NATIVE )
- elif use jemalloc && ! use tbb; then
- mycmakeargs+=( -DUSE_MMGR_TYPE=JEMALLOC )
- elif ! use jemalloc && use tbb; then
- mycmakeargs+=( -DUSE_MMGR_TYPE=TBB )
- elif use jemalloc && use tbb; then
- mycmakeargs+=( -DUSE_MMGR_TYPE=FLEXIBLE )
- fi
-
if use doc; then
mycmakeargs+=(
-DINSTALL_DOC_Overview="yes"
@@ -209,12 +197,6 @@ src_configure() {
)
fi
- if use jemalloc; then
- mycmakeargs+=(
- -D3RDPARTY_JEMALLOC_INCLUDE_DIR="${ESYSROOT}/usr/include/jemalloc"
- )
- fi
-
if use tbb; then
mycmakeargs+=(
-D3RDPARTY_TBB_DIR="${ESYSROOT}/usr"
@@ -297,6 +279,9 @@ src_test() {
'opengl drivers opengles'
'opengles3'
+ 'offset wire_closed_inside_0_005 D1'
+ 'offset wire_unclosed_outside_0_025 A1'
+
'demo draw bug30430'
)